kmod-dm9000 should build as a module
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Jul 2011 18:21:01 +0000 (18:21 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Jul 2011 18:21:01 +0000 (18:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27543 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netdevices.mk

index 9a46689..2cbc3c1 100644 (file)
@@ -626,10 +626,12 @@ $(eval $(call KernelPackage,ifb))
 
 define KernelPackage/dm9000
   SUBMENU:=$(NETWORK_DEVICES_MENU)
-  TITLE:=Davicom 9000 Ethernet support (in-kernel)
-  KCONFIG:=CONFIG_DM9000=y \
+  TITLE:=Davicom 9000 Ethernet support
+  KCONFIG:=CONFIG_DM9000 \
     CONFIG_DM9000_DEBUGLEVEL=4 \
     CONFIG_DM9000_FORCE_SIMPLE_PHY_POLL=y
+  FILES:=$(LINUX_DIR)/drivers/net/dm9000.ko
+  AUTOLOAD:=$(call AutoLoad,34,dm9000)
 endef
 
 define KernelPackage/dm9000/description