ramips: add profile and build image for the Upvel UR-326N4G board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Mar 2013 21:02:45 +0000 (21:02 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Mar 2013 21:02:45 +0000 (21:02 +0000)
Patch from: Дмитрий Лебедев <lebedev@trendnet.ru>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35972 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/upvel.mk

index 67a6f60..6ff1bb1 100644 (file)
@@ -633,6 +633,9 @@ define Image/Build/Profile/WR5123GN
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,wr512-3gn-8M,WR512-3GN,ttyS1,57600,phys)
 endef
 
+define Image/Build/Profile/UPVEL_326
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,ur-326n4g,UR-326N4G,ttyS1,57600,phys)
+endef
 
 define Image/Build/Profile/UPVEL
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,ur-336un,UR-336UN,ttyS1,57600,phys)
@@ -673,6 +676,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/NBG419N,$(1))
        $(call Image/Build/Profile/NW718,$(1))
        $(call Image/Build/Profile/OMNIEMB,$(1))
+       $(call Image/Build/Profile/UPVEL_326,$(1))
        $(call Image/Build/Profile/PSR680W,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
index fa1c993..aff2b94 100644 (file)
@@ -16,3 +16,15 @@ define Profile/UPVEL/Description
        Default package set compatible with URVEL router board.
 endef
 $(eval $(call Profile,UPVEL))
+
+define Profile/UPVEL_326
+       NAME:=UPVEL UR-326N4G
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-rt305x-dwc_otg \
+               kmod-ledtrig-usbdev
+endef
+
+define Profile/UPVEL/Description
+       Default package set compatible with URVEL router board.
+endef
+$(eval $(call Profile,UPVEL_326))