include: export staging_dir/host/bin path from within host.mk (#18957)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Feb 2015 15:49:17 +0000 (15:49 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Feb 2015 15:49:17 +0000 (15:49 +0000)
We need to do that to pickup the prereq-build prepared symlinks for auxillary
operations like metadata scanning.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44378 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host.mk

index 4ca8140..f7368de 100644 (file)
@@ -13,6 +13,8 @@ endif
 ifneq ($(__host_inc),1)
 __host_inc:=1
 
+export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
+
 try-run = $(shell set -e; \
        TMP_F="$(TMP_DIR)/try-run.$$$$.tmp"; \
        if ($(1)) >/dev/null 2>&1; then echo "$(2)"; else echo "$(3)"; fi; \