brcm47xx: build b44 as a module
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Jan 2013 02:00:25 +0000 (02:00 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Jan 2013 02:00:25 +0000 (02:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34994 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netdevices.mk
target/linux/brcm47xx/base-files/lib/preinit/05_init_interfaces_brcm
target/linux/brcm47xx/config-3.6
target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
target/linux/brcm47xx/profiles/104-Broadcom-ath5k.mk
target/linux/brcm47xx/profiles/105-Broadcom-none.mk
target/linux/brcm47xx/profiles/PS-1208MFG.mk
target/linux/brcm47xx/profiles/WGT634U.mk
target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk
target/linux/brcm47xx/profiles/WRTSL54GS.mk

index bab3d70..83d7c5f 100644 (file)
@@ -419,7 +419,7 @@ $(eval $(call KernelPackage,e1000e))
 define KernelPackage/b44
   TITLE:=Broadcom 44xx driver
   KCONFIG:=CONFIG_B44
-  DEPENDS:=@PCI_SUPPORT +kmod-ssb
+  DEPENDS:=@PCI_SUPPORT +!TARGET_brcm47xx:kmod-ssb
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/broadcom/b44.ko
   AUTOLOAD:=$(call AutoLoad,50,b44)
index 3ca8456..d4a3b68 100644 (file)
@@ -6,6 +6,7 @@ set_preinit_iface() {
        insmod diag
        insmod hwmon
        insmod tg3
+       insmod b44
 
        # hardware specific overrides
        case "$(cat /proc/diag/model)" in
index 421590c..ae56ccf 100644 (file)
@@ -7,10 +7,6 @@ CONFIG_ARCH_REQUIRE_GPIOLIB=y
 CONFIG_ARCH_SUSPEND_POSSIBLE=y
 CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
 # CONFIG_ARPD is not set
-CONFIG_B44=y
-CONFIG_B44_PCI=y
-CONFIG_B44_PCICORE_AUTOSELECT=y
-CONFIG_B44_PCI_AUTOSELECT=y
 CONFIG_BCM47XX=y
 CONFIG_BCM47XX_BCMA=y
 CONFIG_BCM47XX_SSB=y
index 7880ce8..54e3909 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-b43
   NAME:=Broadcom BCM43xx WiFi (b43, default)
-  PACKAGES:=kmod-b43 kmod-b43legacy
+  PACKAGES:=kmod-b44 kmod-b43 kmod-b43legacy
 endef
 
 define Profile/Broadcom-b43/Description
index 1464b7e..bad38de 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-wl
   NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
-  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
+  PACKAGES:=-wpad-mini kmod-b44 kmod-brcm-wl wlc nas
 endef
 
 define Profile/Broadcom-wl/Description
index 32baa08..56a505a 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-ath5k
   NAME:=Atheros WiFi (ath5k)
-  PACKAGES:=kmod-ath5k
+  PACKAGES:=kmod-b44 kmod-ath5k
 endef
 
 define Profile/Atheros/Description
index 04ad25d..d048136 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Broadcom-none
   NAME:=No WiFi
-  PACKAGES:=-wpad-mini
+  PACKAGES:=-wpad-mini kmod-b44
 endef
 
 define Profile/None/Description
index 5d7388b..8d8aa68 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Ps1208mfg
   NAME:=Edimax PS-1208MFG
-  PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-mini block-mount kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -kmod-switch kmod-fs-ext4 block-extroot
+  PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-mini kmod-b44 block-mount kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -kmod-switch kmod-fs-ext4 block-extroot
 endef
 
 define Profile/Ps1208mfg/Description
index 81f59a7..689b673 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WGT634U
   NAME:=Netgear WGT634U
-  PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf kmod-crypto-ocf-ubsec-ssb
+  PACKAGES:=kmod-b44 kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf kmod-crypto-ocf-ubsec-ssb
 endef
 
 define Profile/WGT634U/Description
index 4d50db3..3cdd8a0 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WL500GPv1
   NAME:=ASUS WL-500g Premium v1 (Atheros WiFi using ath5k)
-  PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
+  PACKAGES:=kmod-b44 kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
 endef
 
 define Profile/WL500GPv1/Description
index 0e53c7d..68d9a17 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WRTSL54GS
   NAME:=Linksys WRTSL54GS
-  PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
+  PACKAGES:=kmod-b44 kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
 endef
 
 define Profile/WRTSL54GS/Description