base-files: add basic procd integration, let procd start (and restart) ubus instead...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Dec 2012 18:56:09 +0000 (18:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Dec 2012 18:56:09 +0000 (18:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34866 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/rc.common
package/ubus/Makefile

index ec69e0c..63350f8 100644 (file)
@@ -28,7 +28,7 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc
+  DEPENDS:=+netifd +libc +procd
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)-$(REVISION)
index fa2df6c..78e2dd4 100755 (executable)
@@ -75,10 +75,41 @@ $EXTRA_HELP
 EOF
 }
 
+# for procd
+start_service() {
+       return 0
+}
+
+stop_service() {
+       return 0
+}
+
 ${INIT_TRACE:+set -x}
 
 . "$initscript"
 
+[ -n "$USE_PROCD" ] && {
+       . $IPKG_INSTROOT/lib/functions/procd.sh
+
+       rc_procd() {
+               procd_open_service "$(basename "$initscript")" "$initscript"
+               "$@"
+               procd_close_service
+       }
+
+       start() {
+               rc_procd start_service "$@"
+       }
+
+       stop() {
+               procd_kill "$(basename "$initscript")" "$1"
+       }
+
+       reload() {
+               start
+       }
+}
+
 ALL_COMMANDS="start stop reload restart boot shutdown enable disable enabled depends ${EXTRA_COMMANDS}"
 list_contains ALL_COMMANDS "$action" || action=help
 [ "$action" = "reload" ] && action='eval reload "$@" || restart "$@" && :'
index 617c767..782079d 100644 (file)
@@ -63,8 +63,7 @@ define Package/ubus/install
 endef
 
 define Package/ubusd/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/ubus.init $(1)/etc/init.d/ubus
+       $(INSTALL_DIR) $(1)/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/ubusd $(1)/sbin/
 endef