curl: allow enabling https protocol
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jan 2015 13:57:56 +0000 (13:57 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 17 Jan 2015 13:57:56 +0000 (13:57 +0000)
Provide optional --enable-https flag for curl.

Signed-off-by: Lars Kruse <devel@sumpfralle.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43997 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/curl/Config.in
package/network/utils/curl/Makefile

index 086f5c2..026dcd6 100644 (file)
@@ -53,6 +53,10 @@ config LIBCURL_HTTP
        bool "Enable HTTP support"
        default y
 
+config LIBCURL_HTTPS
+       bool "Enable HTTPS support"
+       default n
+
 config LIBCURL_IMAP
        bool "Enable IMAP support"
        default n
index f78fa9e..1a37495 100644 (file)
@@ -37,6 +37,7 @@ PKG_CONFIG_DEPENDS := \
   LIBCURL_GNUTLS \
   LIBCURL_GOPHER \
   LIBCURL_HTTP \
+  LIBCURL_HTTPS \
   LIBCURL_IMAP \
   LIBCURL_LDAP \
   LIBCURL_LDAPS \
@@ -113,6 +114,7 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LIBCURL_GOPHER),--enable,--disable)-gopher \
        $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
        $(if $(CONFIG_LIBCURL_HTTP),--enable,--disable)-http \
+       $(if $(CONFIG_LIBCURL_HTTPS),--enable,--disable)-https \
        $(if $(CONFIG_LIBCURL_IMAP),--enable,--disable)-imap \
        $(if $(CONFIG_LIBCURL_LDAP),--enable,--disable)-ldap \
        $(if $(CONFIG_LIBCURL_LDAPS),--enable,--disable)-ldaps \