Fix dependencies and build (#1849)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2007 08:08:59 +0000 (08:08 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2007 08:08:59 +0000 (08:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7555 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/spca5xx-view/Makefile

index 772655c..263896e 100644 (file)
@@ -24,14 +24,14 @@ define Package/spca5xx-view
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=spca5xx streaming applicaton
-  DEPENDS:=kmod-spca5xx-le libpthread
+  DEPENDS:=+kmod-spca5xx-le +libpthread
   DESCRIPTION:=\
        This package contains a streaming daemon for spca5xx based webcams 
   URL:=http://www.acmesystems.it
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ CFLAGS=$(TARTGET_CFLAGS) CC=$(TARGET_CC) 
+       $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ CFLAGS=$(TARTGET_CFLAGS) CC=$(TARGET_CC) all
        $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ PREFIX="$(PKG_INSTALL_DIR)" install
 endef