ar71xx: add support for dir 505 a1
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Aug 2013 10:41:48 +0000 (10:41 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Aug 2013 10:41:48 +0000 (10:41 +0000)
this patch is based on ...

-> https://forum.openwrt.org/viewtopic.php?pid=179902#p179902

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37703 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/uci-defaults/01_leds
target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-3.10
target/linux/ar71xx/files/arch/mips/ath79/mach-dir-505-a1.c [new file with mode: 0644]
target/linux/ar71xx/generic/profiles/d-link.mk
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch [new file with mode: 0644]

index 48c30ee..7b790e2 100755 (executable)
@@ -43,6 +43,7 @@ get_status_led() {
        db120)
                status_led="db120:green:status"
                ;;
+       dir-505-a1 |\
        dir-600-a1 |\
        dir-615-e4)
                status_led="d-link:green:power"
index 2db8941..f55f1fe 100755 (executable)
@@ -57,6 +57,10 @@ rb-750)
        ucidef_set_led_switch "port5" "port5" "rb750:green:port5" "switch0" "0x02"
        ;;
 
+dir-505-a1)
+       ucidef_set_led_netdev "lan" "LAN" "d-link:green:power" "eth1"
+       ;;
+
 dir-600-a1|\
 dir-615-e4)
        ucidef_set_led_netdev "wan" "WAN" "d-link:green:wan" "eth1"
index 3d09751..176c485 100755 (executable)
@@ -222,6 +222,10 @@ wp543)
        ucidef_set_interface_lan "eth0"
        ;;
 
+dir-505-a1)
+       ucidef_set_interface_lan "eth1"
+       ;;
+
 alfa-ap96 |\
 alfa-nx |\
 ap83 |\
index 14fdfb1..d64e4a0 100755 (executable)
@@ -243,6 +243,9 @@ ar71xx_board_detect() {
        *"DB120 reference board")
                name="db120"
                ;;
+       *"DIR-505 rev. A1")
+               name="dir-505-a1"
+               ;;
        *"DIR-600 rev. A1")
                name="dir-600-a1"
                ;;
@@ -396,6 +399,9 @@ ar71xx_board_detect() {
        *TL-WR2543N*)
                name="tl-wr2543n"
                ;;
+       *DIR-505-A1)
+               name="dir-505-a1"
+               ;;
        *"DIR-615 rev. C1")
                name="dir-615-c1"
                ;;
index 308b4f1..1b3273d 100755 (executable)
@@ -105,6 +105,7 @@ platform_check_image() {
        ap81 | \
        ap83 | \
        ap132 | \
+       dir-505-a1 | \
        dir-600-a1 | \
        dir-615-c1 | \
        dir-615-e4 | \
index 8695bad..6c75f14 100644 (file)
@@ -38,6 +38,7 @@ CONFIG_ATH79_MACH_AW_NR580=y
 CONFIG_ATH79_MACH_CAP4200AG=y
 CONFIG_ATH79_MACH_CARAMBOLA2=y
 CONFIG_ATH79_MACH_DB120=y
+CONFIG_ATH79_MACH_DIR_505_A1=y
 CONFIG_ATH79_MACH_DIR_600_A1=y
 CONFIG_ATH79_MACH_DIR_615_C1=y
 CONFIG_ATH79_MACH_DIR_825_B1=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-dir-505-a1.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-dir-505-a1.c
new file mode 100644 (file)
index 0000000..651bb76
--- /dev/null
@@ -0,0 +1,126 @@
+/*
+ *  DLink DIR-505 A1 board support
+ *
+ *  Copyright (C) 2013 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "dev-usb.h"
+#include "machtypes.h"
+
+#define DIR_505A1_GPIO_BTN_WPS         11 /* verify */
+#define DIR_505A1_GPIO_BTN_RESET       12 /* verify */
+
+#define DIR_505A1_GPIO_LED_RED         26 /* unused, fyi */
+#define DIR_505A1_GPIO_LED_GREEN       27
+
+#define DIR_505A1_GPIO_WAN_LED_ENABLE  1
+
+#define DIR_505A1_KEYS_POLL_INTERVAL   20      /* msecs */
+#define DIR_505A1_KEYS_DEBOUNCE_INTERVAL (3 * DIR_505A1_KEYS_POLL_INTERVAL)
+
+#define DIR_505A1_ART_ADDRESS          0x1f010000
+#define DIR_505A1_CALDATA_OFFSET       0x1000
+#define DIR_505A1_LAN_MAC_ADDRESS      0x1f020004
+#define DIR_505A1_WAN_MAC_ADDRESS      0x1f020016
+
+static struct gpio_led dir_505_a1_leds_gpio[] __initdata = {
+       {
+               .name           = "d-link:green:power",
+               .gpio           = DIR_505A1_GPIO_LED_GREEN,
+               .active_low     = 1,
+       }, {
+               .name           = "d-link:red:status",
+               .gpio           = DIR_505A1_GPIO_LED_RED,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button dir_505_a1_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = DIR_505A1_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DIR_505A1_GPIO_BTN_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "WPS button",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .debounce_interval = DIR_505A1_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = DIR_505A1_GPIO_BTN_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init dir_505_a1_read_ascii_mac(u8 *dest, unsigned int src_addr)
+{
+       int ret;
+       u8 *src = (u8 *)KSEG1ADDR(src_addr);
+
+       ret = sscanf(src, "%02hhx:%02hhx:%02hhx:%02hhx:%02hhx:%02hhx",
+                       &dest[0], &dest[1], &dest[2],
+                       &dest[3], &dest[4], &dest[5]);
+
+       if (ret != ETH_ALEN)
+               memset(dest, 0, ETH_ALEN);
+}
+
+static void __init dir_505_a1_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(DIR_505A1_ART_ADDRESS);
+       u8 lan_mac[ETH_ALEN];
+       u8 wan_mac[ETH_ALEN];
+
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       ath79_gpio_function_disable(AR933X_GPIO_FUNC_ETH_SWITCH_LED0_EN |
+               AR933X_GPIO_FUNC_ETH_SWITCH_LED1_EN |
+               AR933X_GPIO_FUNC_ETH_SWITCH_LED2_EN |
+               AR933X_GPIO_FUNC_ETH_SWITCH_LED3_EN |
+               AR933X_GPIO_FUNC_ETH_SWITCH_LED4_EN);
+
+       gpio_request_one(DIR_505A1_GPIO_WAN_LED_ENABLE,
+               GPIOF_OUT_INIT_LOW, "WAN LED enable");
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(dir_505_a1_leds_gpio),
+               dir_505_a1_leds_gpio);
+
+       ath79_register_gpio_keys_polled(1, DIR_505A1_KEYS_POLL_INTERVAL,
+               ARRAY_SIZE(dir_505_a1_gpio_keys),
+               dir_505_a1_gpio_keys);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_usb();
+
+       dir_505_a1_read_ascii_mac(lan_mac, DIR_505A1_LAN_MAC_ADDRESS);
+       dir_505_a1_read_ascii_mac(wan_mac, DIR_505A1_WAN_MAC_ADDRESS);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, wan_mac, 0);
+       ath79_init_mac(ath79_eth1_data.mac_addr, lan_mac, 0);
+
+       ath79_register_mdio(0, 0x0);
+       ath79_register_eth(1);
+       ath79_register_eth(0);
+
+       ath79_register_wmac(art + DIR_505A1_CALDATA_OFFSET, lan_mac);
+}
+
+MIPS_MACHINE(ATH79_MACH_DIR_505_A1, "DIR-505-A1",
+               "D-Link DIR-505 rev. A1", dir_505_a1_setup);
index 47a6bec..dbb2c6a 100644 (file)
@@ -5,6 +5,17 @@
 # See /LICENSE for more information.
 #
 
+define Profile/DIR505A1
+       NAME:=D-Link DIR-505 rev. A1
+       PACKAGES:=
+endef
+
+define Profile/DIR505A1/Description
+       Package set optimized for the D-Link DIR-505 rev. A1.
+endef
+
+$(eval $(call Profile,DIR505A1))
+
 define Profile/DIR600A1
        NAME:=D-Link DIR-600 rev. A1
        PACKAGES:=
index a9f1f9e..b244b9c 100644 (file)
@@ -164,6 +164,7 @@ ap136_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1
 cameo7240_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(nvram)ro,3712k(firmware),64k(mac)ro,64k(art)ro
 cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,3840k(firmware),64k(art)ro
 cameo933x_mtdlayout=mtdparts=spi0.0:64k(u-boot)ro,64k(art)ro,64k(mac)ro,64k(nvram)ro,192k(language)ro,3648k(firmware)
+cameo933x_mtdlayout_8M=mtdparts=spi0.0:64k(u-boot)ro,64k(art)ro,64k(mac)ro,64k(nvram)ro,256k(language)ro,1024k(kernel),6656k(rootfs),7680k@0x80000(firmware)
 cameo934x_mtdlayout=mtdparts=spi0.0:64k(uboot)ro,64k(nvram)ro,15936k(firmware),192k(lang)ro,64k(mac)ro,64k(art)ro
 cap4200ag_mtdlayout=mtdparts=spi0.0:256k(u-boot),64k(u-boot-env),320k(custom)ro,1536k(kernel),12096k(rootfs),2048k(failsafe),64k(art),13632k@0xa0000(firmware)
 db120_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(nvram),64k(art)ro,7744k@0x50000(firmware)
@@ -384,7 +385,15 @@ define Image/Build/Cameo933x
 endef
 
 define Image/Build/Cameo933x/initramfs
-       $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo933x_mtdlayout))
+       $(call MkuImageLzma/initramfs,$(2),$(3),$(cameo933x_mtdlayout))
+endef
+
+define Image/Build/Cameo933x_8M
+       $(call Image/Build/CameoHornet,$(1),$(2),$(3),$(cameo933x_mtdlayout_8M),1048576,6422528,$(4))
+endef
+
+define Image/Build/Cameo933x_8M/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo933x_mtdlayout_8M))
 endef
 
 define Image/Build/Cameo934x
@@ -392,7 +401,7 @@ define Image/Build/Cameo934x
 endef
 
 define Image/Build/Cameo934x/initramfs
-       $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo934x_mtdlayout))
+       $(call Image/Build/Cameo,$(1),$(2),$(3) $(cameo934x_mtdlayout))
 endef
 
 define Image/Build/Ath
@@ -900,6 +909,7 @@ $(eval $(call SingleProfile,Cameo913x,$(fs_squash),TEW652BRP_RECOVERY,tew-652brp
 
 $(eval $(call SingleProfile,Cameo933x,$(fs_squash),TEW712BR,tew-712br,TEW-712BR,ttyATH0,115200,"HORNET-RT-TEW712BR-3",1.99,""))
 $(eval $(call SingleProfile,Cameo933x,$(fs_squash),DIR601B1,dir-601-b1,TEW-712BR,ttyATH0,115200,"HORNET-RT-DIR601B1-3",2.99.99,"" "NA"))
+$(eval $(call SingleProfile,Cameo933x_8M,$(fs_squash),DIR505A1,dir-505-a1,DIR-505-A1,ttyATH0,115200,"HORNET-RT-DIR505A1-3"))
 
 $(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR825C1,dir-825-c1,DIR-825-C1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))
 $(eval $(call SingleProfile,Cameo934x,$(fs_64k),DIR835A1,dir-835-a1,DIR-835-A1,ttyS0,115200,"00DB120AR9344-RT-101214-00"))
diff --git a/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch b/target/linux/ar71xx/patches-3.10/623-MIPS-ath79-DIR505-support.patch
new file mode 100644 (file)
index 0000000..ee41f65
--- /dev/null
@@ -0,0 +1,45 @@
+Index: linux-3.10.4/arch/mips/ath79/Kconfig
+===================================================================
+--- linux-3.10.4.orig/arch/mips/ath79/Kconfig  2013-08-04 19:08:12.739921385 +0200
++++ linux-3.10.4/arch/mips/ath79/Kconfig       2013-08-04 19:09:15.379922883 +0200
+@@ -254,6 +254,16 @@
+       select ATH79_DEV_USB
+       select MYLOADER
++config ATH79_MACH_DIR_505_A1
++      bool "D-Link DIR-505-A1 support"
++      select SOC_AR933X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_WMAC
++      select ATH79_NVRAM
++
+ config ATH79_MACH_DIR_600_A1
+       bool "D-Link DIR-600 A1/DIR-615 E4 support"
+       select SOC_AR724X
+Index: linux-3.10.4/arch/mips/ath79/Makefile
+===================================================================
+--- linux-3.10.4.orig/arch/mips/ath79/Makefile 2013-08-04 19:07:36.299920522 +0200
++++ linux-3.10.4/arch/mips/ath79/Makefile      2013-08-04 19:09:42.363923523 +0200
+@@ -53,6 +53,7 @@
+ obj-$(CONFIG_ATH79_MACH_AW_NR580)     += mach-aw-nr580.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG)    += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_DB120)                += mach-db120.o
++obj-$(CONFIG_ATH79_MACH_DIR_505_A1)   += mach-dir-505-a1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_600_A1)   += mach-dir-600-a1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_615_C1)   += mach-dir-615-c1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_825_B1)   += mach-dir-825-b1.o
+Index: linux-3.10.4/arch/mips/ath79/machtypes.h
+===================================================================
+--- linux-3.10.4.orig/arch/mips/ath79/machtypes.h      2013-08-04 19:08:12.739921385 +0200
++++ linux-3.10.4/arch/mips/ath79/machtypes.h   2013-08-04 19:09:29.715923222 +0200
+@@ -37,6 +37,7 @@
+       ATH79_MACH_CARAMBOLA2,          /* 8devices Carambola2 */
+       ATH79_MACH_DB120,               /* Atheros DB120 reference board */
+       ATH79_MACH_PB44,                /* Atheros PB44 reference board */
++      ATH79_MACH_DIR_505_A1,          /* D-Link DIR-505 rev. A1 */
+       ATH79_MACH_DIR_600_A1,          /* D-Link DIR-600 rev. A1 */
+       ATH79_MACH_DIR_615_C1,          /* D-Link DIR-615 rev. C1 */
+       ATH79_MACH_DIR_615_E4,          /* D-Link DIR-615 rev. E4 */