[kirkwood] Fix mv_cesa module dependencies and .ko file location
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 28 Sep 2010 16:32:08 +0000 (16:32 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 28 Sep 2010 16:32:08 +0000 (16:32 +0000)
Thanks KanjiMonster & Memphiz

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23145 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/kirkwood/modules.mk

index ed7fe88..736c82c 100644 (file)
@@ -2,10 +2,10 @@
 define KernelPackage/crypto-mv_cesa
    TITLE:=Marvell crypto engine
    KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/crypto/mv_cesa.ko
+   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
    AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
    SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core
+   DEPENDS:=kmod-crypto-core @TARGET_kirkwood
 endef
 
 $(eval $(call KernelPackage,crypto-mv_cesa))