[x86] geos: support cpu MSR register and flashrom for coreboot upgrades
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Mar 2011 21:31:02 +0000 (21:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 28 Mar 2011 21:31:02 +0000 (21:31 +0000)
The early versions of the platform shipped with coreboot 3.0, which had some issues rebooting correctly the first time.

Allow the user to upgrade his BIOS from Linux.

Signed-of-by: Philip Prindeville <philipp@redfish-solutions.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26344 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/geos/target.mk

index faf6166..324525f 100644 (file)
@@ -16,8 +16,10 @@ DEFAULT_PACKAGES += kmod-ata-via-sata \
             kmod-cfg80211 kmod-mac80211 \
             kmod-mppe kmod-pppoe kmod-pppoa kmod-pppol2tp \
             kmod-ath kmod-ath5k kmod-ath9k \
+            kmod-cpu-msr \
             soloscli linux-atm br2684ctl bridge ppp ppp-mod-pppoa \
-            libopenssl ocf-crypto-headers zlib hwclock hostapd
+            libopenssl ocf-crypto-headers zlib hwclock hostapd \
+            flashrom
 
 CS5535_MASK:=0x0E000048