kernel: Add kernel module for Freescale SNVS RTC on chip module
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Jan 2016 12:02:11 +0000 (12:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 Jan 2016 12:02:11 +0000 (12:02 +0000)
Signed-off-by: Petr Štetiar <ynezz@true.cz>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48454 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index b244fbe..528d32f 100644 (file)
@@ -666,6 +666,22 @@ endef
 
 $(eval $(call KernelPackage,rtc-pt7c4338))
 
+define KernelPackage/rtc-snvs
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Freescale SNVS RTC support
+  DEPENDS:=@TARGET_imx6 @RTC_SUPPORT
+  KCONFIG:=CONFIG_RTC_DRV_SNVS \
+       CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-snvs.ko
+  AUTOLOAD:=$(call AutoLoad,50,rtc-snvs,1)
+endef
+
+define KernelPackage/rtc-snvs/description
+ Kernel module for Freescale SNVS RTC on chip module
+endef
+
+$(eval $(call KernelPackage,rtc-snvs))
+
 
 define KernelPackage/mtdtests
   SUBMENU:=$(OTHER_MENU)