package/compcache: move configuration in submenu
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Apr 2010 09:54:27 +0000 (09:54 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Apr 2010 09:54:27 +0000 (09:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20906 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/compcache/Config.in
package/compcache/Makefile

index 9904237..11a94d4 100644 (file)
@@ -1,15 +1,14 @@
-# compcache configuration
+menu "Configuration"
+       depends on PACKAGE_kmod-compcache
 
 config COMPCACHE_ENABLE
        bool "enabled on boot"
        default n
-       depends on PACKAGE_kmod-compcache
        help
          Enables compressed ram swap devices.
 
 config COMPCACHE_RAM_REPORTED
        string "swap space reported to kernel in kb"
-       depends on PACKAGE_kmod-compcache
        default "2048"
        help
          This is the amount of memory that will be reported 
@@ -21,10 +20,10 @@ config COMPCACHE_RAM_REPORTED
 
 config COMPCACHE_BACKUP_DEV
        string "Backup device for compcache"
-       depends on PACKAGE_kmod-compcache
        default ""
        help
          Compcache will use this as a backup device for swap.
          Example:
                 /dev/sda5
 
+endmenu
index 2fec289..13a9056 100644 (file)
@@ -26,6 +26,7 @@ define KernelPackage/compcache
   VERSION:=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)+$(PKG_RELEASE)
   FILES:=$(PKG_BUILD_DIR)/ramzswap.$(LINUX_KMOD_SUFFIX) \
         $(PKG_BUILD_DIR)/sub-projects/compression/lzo-kmod/lzo1x.$(LINUX_KMOD_SUFFIX)
+  MENU:=1
 endef