kernel: remove obsolete CompareKernelPatchVer calls
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 May 2012 15:28:02 +0000 (15:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 17 May 2012 15:28:02 +0000 (15:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31775 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/block.mk
package/kernel/modules/crypto.mk
package/kernel/modules/fs.mk
package/kernel/modules/netsupport.mk
package/kernel/modules/other.mk
package/kernel/modules/pcmcia.mk
package/kernel/modules/video.mk
package/kernel/modules/virtual.mk

index 5096ade..1f343dd 100644 (file)
@@ -43,13 +43,10 @@ endef
 define KernelPackage/ata-ahci
   TITLE:=AHCI Serial ATA support
   KCONFIG:=CONFIG_SATA_AHCI
-  FILES:=$(LINUX_DIR)/drivers/ata/ahci.ko
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
-    FILES += $(LINUX_DIR)/drivers/ata/libahci.ko
-    AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
-  else
-    AUTOLOAD:=$(call AutoLoad,41,ahci,1)
-  endif
+  FILES:= \
+    $(LINUX_DIR)/drivers/ata/ahci.ko \
+    $(LINUX_DIR)/drivers/ata/libahci.ko
+  AUTOLOAD:=$(call AutoLoad,41,libahci ahci,1)
   $(call AddDepends/ata)
 endef
 
@@ -343,17 +340,8 @@ $(call KernelPackage/md/Depends,)
        $(LINUX_DIR)/crypto/async_tx/async_xor.ko \
        $(LINUX_DIR)/crypto/async_tx/async_pq.ko \
        $(LINUX_DIR)/crypto/async_tx/async_raid6_recov.ko \
-       $(LINUX_DIR)/drivers/md/raid456.ko
-  # Additional files with kernel-dependent locations or presence
-  # For Linux >= 2.6.36
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.36)), 1)
-    FILES+= \
+       $(LINUX_DIR)/drivers/md/raid456.ko \
        $(LINUX_DIR)/lib/raid6/raid6_pq.ko
-  # For Linux < 2.6.36
-  else
-    FILES+= \
-       $(LINUX_DIR)/drivers/md/raid6_pq.ko
-  endif
   AUTOLOAD:=$(call AutoLoad,28, xor async_tx async_memcpy async_xor raid6_pq async_pq async_raid6_recov raid456)
 endef
 
index 2331067..3c1528e 100644 (file)
@@ -374,12 +374,8 @@ define KernelPackage/crypto-misc
        $(LINUX_DIR)/crypto/tea.ko \
        $(LINUX_DIR)/crypto/tgr192.ko \
        $(LINUX_DIR)/crypto/twofish_common.ko \
-       $(LINUX_DIR)/crypto/wp512.ko
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.35)),1)
-    FILES += $(LINUX_DIR)/crypto/twofish.ko
-  else
-    FILES += $(LINUX_DIR)/crypto/twofish_generic.ko
-  endif
+       $(LINUX_DIR)/crypto/wp512.ko \
+    $(LINUX_DIR)/crypto/twofish_generic.ko
   ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,3.1)),1)
     FILES += $(LINUX_DIR)/crypto/blowfish.ko
   else
index 1d65f66..cd6db90 100644 (file)
@@ -91,14 +91,9 @@ define KernelPackage/fs-ext4
        CONFIG_JBD2
   FILES:= \
        $(LINUX_DIR)/fs/ext4/ext4.ko \
-       $(LINUX_DIR)/fs/jbd2/jbd2.ko
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),1)
-    FILES+= \
+       $(LINUX_DIR)/fs/jbd2/jbd2.ko \
        $(LINUX_DIR)/fs/mbcache.ko
-    AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
- else
-    AUTOLOAD:=$(call AutoLoad,30,jbd2 ext4,1)
- endif
+  AUTOLOAD:=$(call AutoLoad,30,mbcache jbd2 ext4,1)
   $(call AddDepends/crc16)
 endef
 
index 23204b4..f122b68 100644 (file)
@@ -438,13 +438,8 @@ define KernelPackage/gre
   TITLE:=GRE support
   DEPENDS:=+PACKAGE_kmod-ipv6:kmod-ipv6
   KCONFIG:=CONFIG_NET_IPGRE CONFIG_NET_IPGRE_DEMUX
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),1)
   FILES:=$(LINUX_DIR)/net/ipv4/ip_gre.ko $(LINUX_DIR)/net/ipv4/gre.ko
   AUTOLOAD:=$(call AutoLoad,39,gre ip_gre)
- else
-  FILES:=$(LINUX_DIR)/net/ipv4/ip_gre.ko
-  AUTOLOAD:=$(call AutoLoad,39,ip_gre)
- endif
 endef
 
 define KernelPackage/gre/description
@@ -572,20 +567,15 @@ define KernelPackage/pptp
 endef
 
 $(eval $(call KernelPackage,pptp))
-       
+
 
 define KernelPackage/pppol2tp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=PPPoL2TP support
   DEPENDS:=kmod-ppp +kmod-pppoe +kmod-l2tp
   KCONFIG:=CONFIG_PPPOL2TP
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
-    FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
-    AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
-  else
-    FILES:=$(LINUX_DIR)/drivers/net/pppol2tp.ko
-    AUTOLOAD:=$(call AutoLoad,40,pppol2tp)
-  endif
+  FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
+  AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
 endef
 
 define KernelPackage/pppol2tp/description
index 1f61da8..9e4559a 100644 (file)
@@ -44,14 +44,7 @@ define KernelPackage/bluetooth
        $(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
        $(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
        $(LINUX_DIR)/drivers/bluetooth/btusb.ko
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.39)),1)
-    AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
-  else
-    FILES+= \
-       $(LINUX_DIR)/net/bluetooth/l2cap.ko \
-       $(LINUX_DIR)/net/bluetooth/sco.ko
-    AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
-  endif
+  AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
 endef
 
 define KernelPackage/bluetooth/description
@@ -922,11 +915,7 @@ define KernelPackage/serial-8250
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
   FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
 else
- ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
   FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
- else
-  FILES:=$(LINUX_DIR)/drivers/serial/8250.ko
- endif
 endif
 endef
 
index 7ea2599..a803a03 100644 (file)
@@ -69,14 +69,10 @@ define KernelPackage/pcmcia-serial
   KCONFIG:= \
        CONFIG_PCMCIA_SERIAL_CS \
        CONFIG_SERIAL_8250_CS
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
-    ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
-       FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
-    else
-       FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
-    endif
+  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+    FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
   else
-    FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.ko
+    FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
   endif
   AUTOLOAD:=$(call AutoLoad,45,serial_cs)
 endef
index e42e818..5ff55c9 100644 (file)
@@ -22,18 +22,10 @@ define KernelPackage/video-core
        CONFIG_V4L_PCI_DRIVERS=y \
        CONFIG_V4L_PLATFORM_DRIVERS=y \
        CONFIG_V4L_ISA_PARPORT_DRIVERS=y
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
   FILES:= \
        $(LINUX_DIR)/drivers/media/video/v4l2-common.ko \
        $(LINUX_DIR)/drivers/media/video/videodev.ko
   AUTOLOAD:=$(call AutoLoad,60, videodev v4l2-common)
-else
-  FILES:= \
-       $(LINUX_DIR)/drivers/media/video/v4l2-common.ko \
-       $(LINUX_DIR)/drivers/media/video/v4l1-compat.ko \
-       $(LINUX_DIR)/drivers/media/video/videodev.ko
-  AUTOLOAD:=$(call AutoLoad,60, v4l1-compat videodev v4l2-common)
-endif
 endef
 
 define KernelPackage/video-core/description
index 6c907a9..0089f93 100644 (file)
@@ -78,13 +78,8 @@ define KernelPackage/xen-evtchn
   TITLE:=Xen event channels
   DEPENDS:=@TARGET_x86_xen_domu
   KCONFIG:=CONFIG_XEN_DEV_EVTCHN
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),1)
-    FILES:=$(LINUX_DIR)/drivers/xen/xen-evtchn.ko
-    AUTOLOAD:=$(call AutoLoad,06,xen-evtchn)
-  else
-    FILES:=$(LINUX_DIR)/drivers/xen/evtchn.ko
-    AUTOLOAD:=$(call AutoLoad,06,evtchn)
-  endif
+  FILES:=$(LINUX_DIR)/drivers/xen/xen-evtchn.ko
+  AUTOLOAD:=$(call AutoLoad,06,xen-evtchn)
 endef
 
 define KernelPackage/xen-evtchn/description