kernel: sctp depends on ipv6 if ipv6 is enabled
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 16:46:11 +0000 (16:46 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 16:46:11 +0000 (16:46 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37406 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netsupport.mk

index 0edfe5f..07ce479 100644 (file)
@@ -865,6 +865,7 @@ $(eval $(call KernelPackage,l2tp-ip))
 define KernelPackage/sctp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=SCTP protocol kernel support
+  DEPENDS:=+IPV6:kmod-ipv6
   KCONFIG:=\
      CONFIG_IP_SCTP \
      CONFIG_SCTP_DBG_MSG=n \