[ramips] initial support for the AP-R3052-V22RW-2X2 board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Sep 2009 15:31:00 +0000 (15:31 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Sep 2009 15:31:00 +0000 (15:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17473 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/common/prom.c
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-v22rw-2x2.c [new file with mode: 0644]
target/linux/ramips/rt305x/config-2.6.30

index 8bc3857..6069181 100644 (file)
 
 enum ramips_mach_type {
        RAMIPS_MACH_GENERIC,
+       /* RT2880 based machines */
        RAMIPS_MACH_RT_N15,             /* Asus RT-N15 */
+
+       /* RT3052 based machines */
+       RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
        RAMIPS_MACH_WHR_G300N,          /* Buffalo WHR-G300N */
 };
 
index edc3c5e..923673b 100644 (file)
@@ -33,6 +33,9 @@ static struct board_rec boards[] __initdata = {
                .name           = "RT-N15",
                .mach_type      = RAMIPS_MACH_RT_N15,
        }, {
+               .name           = "V22RW-2X2",
+               .mach_type      = RAMIPS_MACH_V22RW_2X2,
+       }, {
                .name           = "WHR-G300N",
                .mach_type      = RAMIPS_MACH_WHR_G300N,
        }
index dc69de0..44f7056 100644 (file)
@@ -7,6 +7,11 @@ config RT305X_MACH_WHR_G300N
        default y
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_V22RW_2X2
+       bool "Ralink AP-RT3052-V22RW-2X2 board support"
+       default y
+       select RALINK_DEV_GPIO_LEDS
+
 endmenu
 
 endif
index c7c1c31..67bcbf6 100644 (file)
@@ -11,4 +11,5 @@ obj-y := irq.o setup.o devices.o rt305x.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
 
+obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-v22rw-2x2.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-v22rw-2x2.c
new file mode 100644 (file)
index 0000000..1186763
--- /dev/null
@@ -0,0 +1,88 @@
+/*
+ *  Ralink AP-RT3052-V22RW-2X2 board support
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+#include <linux/leds.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev_gpio_leds.h>
+
+#include "devices.h"
+
+#define V22RW_2X2_GPIO_LED_SECURITY    13
+#define V22RW_2X2_GPIO_LED_WPS         14
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition v22rw_2x2_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "u-boot-env",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0a0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x150000,
+               .size   = 0x2b0000,
+       }, {
+               .name   = "openwrt",
+               .offset = 0x050000,
+               .size   = 0x3b0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data v22rw_2x2_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(v22rw_2x2_partitions),
+       .parts          = v22rw_2x2_partitions,
+#endif
+};
+
+static struct gpio_led v22rw_2x2_leds_gpio[] __initdata = {
+       {
+               .name           = "v22rw-2x2:green:security",
+               .gpio           = V22RW_2X2_GPIO_LED_SECURITY,
+               .active_low     = 1,
+       }, {
+               .name           = "v22rw-2x2:red:wps",
+               .gpio           = V22RW_2X2_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init v22rw_2x2_init(void)
+{
+       rt305x_register_flash(0, &v22rw_2x2_flash_data);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(v22rw_2x2_leds_gpio),
+                                 v22rw_2x2_leds_gpio);
+}
+
+MIPS_MACHINE(RAMIPS_MACH_V22RW_2X2, "Ralink AP-RT3052-V22RW-2X2",
+            v22rw_2x2_init);
index cbec838..43376c5 100644 (file)
@@ -116,6 +116,7 @@ CONFIG_PHYLIB=y
 CONFIG_RALINK_DEV_GPIO_LEDS=y
 # CONFIG_RALINK_RT288X is not set
 CONFIG_RALINK_RT305X=y
+CONFIG_RT305X_MACH_V22RW_2X2=y
 CONFIG_RT305X_MACH_WHR_G300N=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set