kernel: crypto: fix module loading of cryptomgr.ko
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Aug 2015 17:17:51 +0000 (17:17 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 9 Aug 2015 17:17:51 +0000 (17:17 +0000)
There was no rule to load this module.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46575 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk

index 7324d1a..d530b14 100644 (file)
@@ -66,6 +66,7 @@ define KernelPackage/crypto-manager
        CONFIG_CRYPTO_MANAGER \
        CONFIG_CRYPTO_MANAGER2
   FILES:=$(LINUX_DIR)/crypto/cryptomgr.ko
+  AUTOLOAD:=$(call AutoLoad,09,cryptomgr,1)
   $(call AddDepends/crypto)
 endef