polarssl: update to 1.3.9
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Nov 2014 19:36:06 +0000 (19:36 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 3 Nov 2014 19:36:06 +0000 (19:36 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43170 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/polarssl/Makefile
package/libs/polarssl/patches/210-gen_key_config_fix.patch [deleted file]

index 739f783..18e0f44 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=polarssl
-PKG_VERSION:=1.3.8
-PKG_RELEASE:=2
+PKG_VERSION:=1.3.9
+PKG_RELEASE:=1
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
 PKG_SOURCE_URL:=https://polarssl.org/code/releases
-PKG_MD5SUM:=d1a2b4f21727e888f143414d2e3144e6
+PKG_MD5SUM:=48af7d1f0d5de512cbd6dacf5407884c
 
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+
diff --git a/package/libs/polarssl/patches/210-gen_key_config_fix.patch b/package/libs/polarssl/patches/210-gen_key_config_fix.patch
deleted file mode 100644 (file)
index b17e744..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/programs/pkey/gen_key.c
-+++ b/programs/pkey/gen_key.c
-@@ -215,7 +215,9 @@ int main( int argc, char *argv[] )
-     opt.type                = DFL_TYPE;
-     opt.rsa_keysize         = DFL_RSA_KEYSIZE;
-+#if defined(POLARSSL_ECP_C)
-     opt.ec_curve            = DFL_EC_CURVE;
-+#endif
-     opt.filename            = DFL_FILENAME;
-     opt.format              = DFL_FORMAT;
-     opt.use_dev_random      = DFL_USE_DEV_RANDOM;
-@@ -231,8 +233,10 @@ int main( int argc, char *argv[] )
-         {
-             if( strcmp( q, "rsa" ) == 0 )
-                 opt.type = POLARSSL_PK_RSA;
-+#if defined(POLARSSL_ECP_C)
-             else if( strcmp( q, "ec" ) == 0 )
-                 opt.type = POLARSSL_PK_ECKEY;
-+#endif
-             else
-                 goto usage;
-         }
-@@ -251,12 +255,14 @@ int main( int argc, char *argv[] )
-             if( opt.rsa_keysize < 1024 || opt.rsa_keysize > 8192 )
-                 goto usage;
-         }
-+#if defined(POLARSSL_ECP_C)
-         else if( strcmp( p, "ec_curve" ) == 0 )
-         {
-             if( ( curve_info = ecp_curve_info_from_name( q ) ) == NULL )
-                 goto usage;
-             opt.ec_curve = curve_info->grp_id;
-         }
-+#endif
-         else if( strcmp( p, "filename" ) == 0 )
-             opt.filename = q;
-         else if( strcmp( p, "use_dev_random" ) == 0 )