update pmacct to new upstream release and add SQLite database support, the update...
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Feb 2006 13:56:55 +0000 (13:56 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 Feb 2006 13:56:55 +0000 (13:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3245 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile
package/pmacct/Config.in
package/pmacct/Makefile
package/pmacct/ipkg/nfacctd-sqlite.control [new file with mode: 0644]
package/pmacct/ipkg/pmacctd-sqlite.control [new file with mode: 0644]

index 47a6821..d05117b 100644 (file)
@@ -488,6 +488,9 @@ endif
 ifneq ($(BR2_COMPILE_PMACCT_PGSQL),)
 pmacct-compile: postgresql-compile
 endif
+ifneq ($(BR2_COMPILE_PMACCT_SQLITE),)
+pmacct-compile: sqlite-compile
+endif
 
 rrs-compile: uclibc++-compile
 ifneq ($(BR2_PACKAGE_RRS),)
index 2976386..76612b3 100644 (file)
@@ -3,7 +3,7 @@ menu "pmacct............................ IPv4/IPv6 accounting and aggregation to
 config BR2_COMPILE_PMACCT
        tristate
        default n
-       depends BR2_COMPILE_PMACCT_BASIC || BR2_COMPILE_PMACCT_MYSQL || BR2_COMPILE_PMACCT_PGSQL || BR2_COMPILE_PMACCT_CUSTOM
+       depends BR2_COMPILE_PMACCT_BASIC || BR2_COMPILE_PMACCT_MYSQL || BR2_COMPILE_PMACCT_PGSQL || BR2_COMPILE_PMACCT_SQLITE || BR2_COMPILE_PMACCT_CUSTOM
 
 config BR2_COMPILE_PMACCT_BASIC
        tristate
@@ -23,6 +23,12 @@ config BR2_COMPILE_PMACCT_PGSQL
        depends BR2_PACKAGE_NFACCTD_PGSQL || BR2_PACKAGE_PMACCTD_PGSQL
        select BR2_COMPILE_PMACCT
 
+config BR2_COMPILE_PMACCT_SQLITE
+       tristate
+       default n
+       depends BR2_PACKAGE_NFACCTD_SQLITE || BR2_PACKAGE_PMACCTD_SQLITE
+       select BR2_COMPILE_PMACCT
+
 config BR2_COMPILE_PMACCT_CUSTOM
        tristate
        default n
@@ -43,7 +49,9 @@ choice
          Depends:
            - libmysqlclient (for MySQL database logging support)
            - libpq (for PostgreSQL database logging support)
-       
+           - libsqlite (for SQLite database logging support)
+
+
        config BR2_PACKAGE_NFACCTD_BASIC
                prompt     "nfacctd.......................   built without database support"
                tristate
@@ -63,7 +71,14 @@ choice
                select BR2_COMPILE_PMACCT_PGSQL
                select BR2_PACKAGE_LIBPCAP
                select BR2_PACKAGE_LIBPQ
-       
+
+       config BR2_PACKAGE_NFACCTD_SQLITE
+               prompt     "nfacctd-sqlite................   built with SQLite database support"
+               tristate
+               select BR2_COMPILE_PMACCT_SQLITE
+               select BR2_PACKAGE_LIBPCAP
+               select BR2_PACKAGE_LIBSQLITE
+
        config BR2_PACKAGE_NFACCTD_CUSTOM
                prompt     "nfacctd-custom................   customized to your needs"
                tristate
@@ -96,6 +111,13 @@ choice
                depends BR2_PACKAGE_NFACCTD_CUSTOM
                select BR2_PACKAGE_LIBPQ
 
+       config BR2_COMPILE_NFACCTD_WITH_SQLITE
+               prompt "SQLite database support"
+               bool
+               default n
+               depends BR2_PACKAGE_NFACCTD_CUSTOM
+               select BR2_PACKAGE_LIBSQLITE
+
 endchoice
 
 choice
@@ -113,7 +135,8 @@ choice
            - libpcap
            - libmysqlclient (for MySQL database logging support)
            - libpq (for PostgreSQL database logging support)
-       
+           - libsqlite (for SQLite database logging support)
+
        
        config BR2_PACKAGE_PMACCTD_BASIC
                prompt     "pmacctd.......................   built without database support"
@@ -134,7 +157,14 @@ choice
                select BR2_COMPILE_PMACCT_PGSQL
                select BR2_PACKAGE_LIBPCAP
                select BR2_PACKAGE_LIBPQ
-       
+
+       config BR2_PACKAGE_PMACCTD_SQLITE
+               prompt     "pmacctd-sqlite................   built with SQLite database support"
+               tristate
+               select BR2_COMPILE_PMACCT_PGSQL
+               select BR2_PACKAGE_LIBPCAP
+               select BR2_PACKAGE_LIBPQ
+
        config BR2_PACKAGE_PMACCTD_CUSTOM
                prompt     "pmacctd-custom................   customized to your needs"
                tristate
@@ -167,6 +197,13 @@ choice
                depends BR2_PACKAGE_PMACCTD_CUSTOM
                select BR2_PACKAGE_LIBPQ
 
+       config BR2_COMPILE_PMACCTD_WITH_SQLITE
+               prompt "SQLite database support"
+               bool
+               default n
+               depends BR2_PACKAGE_PMACCTD_CUSTOM
+               select BR2_PACKAGE_LIBSQLITE
+
 endchoice
 
 config BR2_PACKAGE_PMACCT_CLIENT
index 4a86c3a..a9bd44b 100644 (file)
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pmacct
-PKG_VERSION:=0.8.7
+PKG_VERSION:=0.10.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=3da0205de772fb6d915e03cadf2a8e9b
+PKG_MD5SUM:=ed510e7ee2130d1f37f27901b89e985a
 
 PKG_SOURCE_URL:=http://www.ba.cnr.it/~paolo/pmacct/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)rc2.tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -28,6 +28,11 @@ PMACCT_PGSQL_CONFIGURE_OPTS := \
        --with-pgsql-includes="$(STAGING_DIR)/usr/include" \
        --with-pgsql-libs="$(STAGING_DIR)/usr/lib"
 
+PMACCT_SQLITE_CONFIGURE_OPTS := \
+       --enable-sqlite3 \
+       --with-sqlite3-includes="$(STAGING_DIR)/usr/include" \
+       --with-sqlite3-libs="$(STAGING_DIR)/usr/lib"
+
 NFACCTD_CUSTOM_CONFIGURE_OPTS := \
 
 ifeq ($(BR2_PACKAGE_NFACCTD_ENABLE_DEBUG),y)
@@ -46,6 +51,10 @@ ifeq ($(BR2_PACKAGE_NFACCTD_WITH_PGSQL),y)
 NFACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_PGSQL_CONFIGURE_OPTS)
 endif
 
+ifeq ($(BR2_PACKAGE_NFACCTD_WITH_SQLITE),y)
+NFACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_SQLITE_CONFIGURE_OPTS)
+endif
+
 PMACCTD_CUSTOM_CONFIGURE_OPTS := \
 
 ifeq ($(BR2_PACKAGE_PMACCTD_ENABLE_DEBUG),y)
@@ -64,6 +73,10 @@ ifeq ($(BR2_PACKAGE_PMACCTD_WITH_PGSQL),y)
 PMACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_PGSQL_CONFIGURE_OPTS)
 endif
 
+ifeq ($(BR2_PACKAGE_PMACCTD_WITH_SQLITE),y)
+PMACCTD_CUSTOM_CONFIGURE_OPTS += $(PMACCT_SQLITE_CONFIGURE_OPTS)
+endif
+
 define PKG_build
 
 ifneq ($(BR2_PACKAGE_$(1)),)
@@ -79,30 +92,30 @@ $(PKG_BUILD_DIR)/$(2) $(PKG_BUILD_DIR)/$(3): $(PKG_BUILD_DIR)/.prepared
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                ./configure \
-                 --target=$(GNU_TARGET_NAME) \
-                 --host=$(GNU_TARGET_NAME) \
-                 --build=$(GNU_HOST_NAME) \
-                 --program-prefix="" \
-                 --program-suffix="" \
-                 --prefix=/usr \
-                 --exec-prefix=/usr \
-                 --bindir=/usr/sbin \
-                 --datadir=/usr/share \
-                 --includedir=/usr/include \
-                 --infodir=/usr/share/info \
-                 --libdir=/usr/lib \
-                 --libexecdir=/usr/lib/locate \
-                 --localstatedir=/var/lib \
-                 --mandir=/usr/share/man \
-                 --sbindir=/usr/sbin \
-                 --sysconfdir=/etc \
-                 $(DISABLE_LARGEFILE) \
-                 $(DISABLE_NLS) \
-                 --enable-shared \
-                 --disable-static \
-                 --with-pcap-includes="$(STAGING_DIR)/usr/include" \
-                 --with-pcap-libs="$(STAGING_DIR)/usr/lib" \
-                 $$($(1)_CONFIGURE_OPTS) \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/sbin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib/locate \
+                       --localstatedir=/var/lib \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --disable-static \
+                       --with-pcap-includes="$(STAGING_DIR)/usr/include" \
+                       --with-pcap-libs="$(STAGING_DIR)/usr/lib" \
+                       $$($(1)_CONFIGURE_OPTS) \
        );
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
@@ -131,26 +144,31 @@ endef
 $(eval $(call PKG_template,NFACCTD_BASIC,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,NFACCTD_MYSQL,nfacctd-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,NFACCTD_PGSQL,nfacctd-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,NFACCTD_SQLITE,nfacctd-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,NFACCTD_CUSTOM,nfacctd-custom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PMACCTD_BASIC,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PMACCTD_MYSQL,pmacctd-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PMACCTD_PGSQL,pmacctd-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,PMACCTD_SQLITE,pmacctd-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PMACCTD_CUSTOM,pmacctd-custom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PMACCT_CLIENT,pmacct-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call PKG_build,PMACCT_BASIC,nfacctd-basic,pmacctd-basic,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_build,PMACCT_MYSQL,nfacctd-mysql,pmacctd-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_build,PMACCT_PGSQL,nfacctd-pgsql,pmacctd-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_build,PMACCT_SQLITE,nfacctd-sqlite,pmacctd-sqlite,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_build,NFACCTD_CUSTOM,nfacctd-custom,pmacctd-dummy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_build,PMACCTD_CUSTOM,nfacctd-dummy,pmacctd-custom,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call PKG_package,NFACCTD_BASIC,nfacctd-basic,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_package,NFACCTD_MYSQL,nfacctd-mysql,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_package,NFACCTD_PGSQL,nfacctd-pgsql,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_package,NFACCTD_SQLITE,nfacctd-sqlite,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_package,NFACCTD_CUSTOM,nfacctd-custom,nfacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_package,PMACCTD_BASIC,pmacctd-basic,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_package,PMACCTD_MYSQL,pmacctd-mysql,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_package,PMACCTD_PGSQL,pmacctd-pgsql,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_package,PMACCTD_SQLITE,pmacctd-sqlite,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_package,PMACCTD_CUSTOM,pmacctd-custom,pmacctd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
diff --git a/package/pmacct/ipkg/nfacctd-sqlite.control b/package/pmacct/ipkg/nfacctd-sqlite.control
new file mode 100644 (file)
index 0000000..add8394
--- /dev/null
@@ -0,0 +1,6 @@
+Package: nfacctd-sqlite
+Priority: optional
+Section: net
+Description: a NetFlow accounting daemon,
+ built with SQLite database support
+Depends: libsqlite, libpcap
diff --git a/package/pmacct/ipkg/pmacctd-sqlite.control b/package/pmacct/ipkg/pmacctd-sqlite.control
new file mode 100644 (file)
index 0000000..ad8f7c9
--- /dev/null
@@ -0,0 +1,6 @@
+Package: pmacctd-sqlite
+Priority: optional
+Section: net
+Description: an IP accounting daemon,
+ built with SQLite database support
+Depends: libsqlite, libpcap