kernel: remove useless AddDepends/input abstraction
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Mar 2015 08:12:39 +0000 (08:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Mar 2015 08:12:39 +0000 (08:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45135 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/001-depends.mk
package/kernel/linux/modules/input.mk
package/kernel/linux/modules/other.mk
package/kernel/linux/modules/sound.mk
package/kernel/linux/modules/usb.mk
package/kernel/linux/modules/video.mk

index 57fc9ab..81192e0 100644 (file)
@@ -5,11 +5,6 @@
 # See /LICENSE for more information.
 #
 
-define AddDepends/input
-  DEPENDS+= +kmod-input-core $(1)
-endef
-
-
 define AddDepends/nls
   DEPENDS+= +kmod-nls-base $(foreach cp,$(1),+kmod-nls-$(cp))
 endef
index 1e8b2f0..6c9f228 100644 (file)
@@ -10,10 +10,10 @@ INPUT_MODULES_MENU:=Input modules
 define KernelPackage/hid
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=HID Devices
+  DEPENDS:=+kmod-input-core +kmod-input-evdev
   KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y
   FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
   AUTOLOAD:=$(call AutoLoad,61,hid)
-  $(call AddDepends/input,+kmod-input-evdev)
 endef
 
 define KernelPackage/hid/description
@@ -54,10 +54,10 @@ $(eval $(call KernelPackage,input-core))
 define KernelPackage/input-evdev
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Input event device
+  DEPENDS:=+kmod-input-core
   KCONFIG:=CONFIG_INPUT_EVDEV
   FILES:=$(LINUX_DIR)/drivers/input/evdev.ko
   AUTOLOAD:=$(call AutoLoad,60,evdev)
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-evdev/description
@@ -70,13 +70,12 @@ $(eval $(call KernelPackage,input-evdev))
 define KernelPackage/input-gpio-keys
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=GPIO key support
-  DEPENDS:= @GPIO_SUPPORT
+  DEPENDS:= @GPIO_SUPPORT +kmod-input-core
   KCONFIG:= \
        CONFIG_KEYBOARD_GPIO \
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys.ko
   AUTOLOAD:=$(call AutoProbe,gpio_keys)
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-gpio-keys/description
@@ -99,7 +98,6 @@ define KernelPackage/input-gpio-keys-polled
        CONFIG_INPUT_KEYBOARD=y
   FILES:=$(LINUX_DIR)/drivers/input/keyboard/gpio_keys_polled.ko
   AUTOLOAD:=$(call AutoProbe,gpio_keys_polled,1)
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-gpio-keys-polled/description
@@ -115,10 +113,10 @@ $(eval $(call KernelPackage,input-gpio-keys-polled))
 define KernelPackage/input-gpio-encoder
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=GPIO rotay encoder
+  DEPENDS:=@GPIO_SUPPORT +kmod-input-core
   KCONFIG:=CONFIG_INPUT_GPIO_ROTARY_ENCODER
   FILES:=$(LINUX_DIR)/drivers/input/misc/rotary_encoder.ko
   AUTOLOAD:=$(call AutoProbe,rotary_encoder)
-  $(call AddDepends/input,@GPIO_SUPPORT)
 endef
 
 define KernelPackage/gpio-encoder/description
@@ -131,10 +129,10 @@ $(eval $(call KernelPackage,input-gpio-encoder))
 define KernelPackage/input-joydev
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Joystick device support
+  DEPENDS:=+kmod-input-core
   KCONFIG:=CONFIG_INPUT_JOYDEV
   FILES:=$(LINUX_DIR)/drivers/input/joydev.ko
   AUTOLOAD:=$(call AutoProbe,joydev)
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-joydev/description
@@ -147,9 +145,9 @@ $(eval $(call KernelPackage,input-joydev))
 define KernelPackage/input-polldev
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Polled Input device support
+  DEPENDS:=+kmod-input-core
   KCONFIG:=CONFIG_INPUT_POLLDEV
   FILES:=$(LINUX_DIR)/drivers/input/input-polldev.ko
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-polldev/description
@@ -162,10 +160,10 @@ $(eval $(call KernelPackage,input-polldev))
 define KernelPackage/input-matrixkmap
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=Input matrix devices support
+  DEPENDS:=+kmod-input-core
   KCONFIG:=CONFIG_INPUT_MATRIXKMAP
   FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
   AUTOLOAD:=$(call AutoProbe,matrix-keymap)
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/input-matrix/description
index c270481..97990b7 100644 (file)
@@ -952,13 +952,13 @@ $(eval $(call KernelPackage,thermal-kirkwood))
 define KernelPackage/gpio-beeper
   SUBMENU:=$(OTHER_MENU)
   TITLE:=GPIO beeper support
+  DEPENDS:=+kmod-input-core
   KCONFIG:= \
        CONFIG_INPUT_MISC=y \
        CONFIG_INPUT_GPIO_BEEPER
   FILES:= \
        $(LINUX_DIR)/drivers/input/misc/gpio-beeper.ko
   AUTOLOAD:=$(call AutoLoad,50,gpio-beeper)
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/gpio-beeper/description
index 9a3caed..54bc30a 100644 (file)
@@ -51,7 +51,7 @@ endif
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
-  DEPENDS:=@AUDIO_SUPPORT
+  DEPENDS:=@AUDIO_SUPPORT +kmod-input-core
   KCONFIG:= \
        CONFIG_SOUND \
        CONFIG_SND \
@@ -70,7 +70,6 @@ define KernelPackage/sound-core
        CONFIG_SND_COMPRESS_OFFLOAD
   FILES:=$(SOUNDCORE_FILES)
   AUTOLOAD:=$(call AutoLoad,30,$(SOUNDCORE_LOAD))
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/sound-core/uml
@@ -233,7 +232,7 @@ $(eval $(call KernelPackage,sound-soc-gw_avila))
 
 
 define KernelPackage/pcspkr
-  DEPENDS:=@TARGET_x86
+  DEPENDS:=@TARGET_x86 +kmod-input-core
   TITLE:=PC speaker support
   KCONFIG:= \
        CONFIG_INPUT_PCSPKR \
@@ -242,7 +241,6 @@ define KernelPackage/pcspkr
        $(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
        $(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
   AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
-  $(call AddDepends/input)
   $(call AddDepends/sound)
 endef
 
index ef803f3..b57ca92 100644 (file)
@@ -1311,11 +1311,10 @@ $(eval $(call KernelPackage,usb-net-kalmia))
 define KernelPackage/usb-hid
   TITLE:=Support for USB Human Input Devices
   KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID CONFIG_USB_HIDDEV=y
-  DEPENDS:=+kmod-hid +kmod-hid-generic
+  DEPENDS:=+kmod-hid +kmod-hid-generic +kmod-input-evdev
   FILES:=$(LINUX_DIR)/drivers/$(USBHID_DIR)/usbhid.ko
   AUTOLOAD:=$(call AutoProbe,usbhid)
   $(call AddDepends/usb)
-  $(call AddDepends/input,+kmod-input-evdev)
 endef
 
 define KernelPackage/usb-hid/description
@@ -1327,11 +1326,11 @@ $(eval $(call KernelPackage,usb-hid))
 
 define KernelPackage/usb-yealink
   TITLE:=USB Yealink VOIP phone
+  DEPENDS:=+kmod-input-evdev
   KCONFIG:=CONFIG_USB_YEALINK CONFIG_INPUT_YEALINK CONFIG_INPUT=m CONFIG_INPUT_MISC=y
   FILES:=$(LINUX_DIR)/drivers/$(USBINPUT_DIR)/yealink.ko
   AUTOLOAD:=$(call AutoProbe,yealink)
   $(call AddDepends/usb)
-  $(call AddDepends/input,+kmod-input-evdev)
 endef
 
 define KernelPackage/usb-yealink/description
@@ -1343,11 +1342,11 @@ $(eval $(call KernelPackage,usb-yealink))
 
 define KernelPackage/usb-cm109
   TITLE:=Support for CM109 device
+  DEPENDS:=+kmod-input-evdev
   KCONFIG:=CONFIG_USB_CM109 CONFIG_INPUT_CM109 CONFIG_INPUT=m CONFIG_INPUT_MISC=y
   FILES:=$(LINUX_DIR)/drivers/$(USBINPUT_DIR)/cm109.ko
   AUTOLOAD:=$(call AutoProbe,cm109)
   $(call AddDepends/usb)
-  $(call AddDepends/input,+kmod-input-evdev)
 endef
 
 define KernelPackage/usb-cm109/description
index 25ef9cb..7a7d80c 100644 (file)
@@ -184,12 +184,11 @@ $(eval $(call KernelPackage,video-pwc))
 
 define KernelPackage/video-uvc
   TITLE:=USB Video Class (UVC) support
-  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2 +kmod-input-core
   KCONFIG:= CONFIG_USB_VIDEO_CLASS
   FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/uvc/uvcvideo.ko
   AUTOLOAD:=$(call AutoProbe,uvcvideo)
   $(call AddDepends/camera)
-  $(call AddDepends/input)
 endef
 
 define KernelPackage/video-uvc/description