package/index: filter out the libc package from the index
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 01:29:11 +0000 (01:29 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 01:29:11 +0000 (01:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32187 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/ipkg-make-index.sh
target/imagebuilder/files/Makefile

index 31b4327..cbfa450 100755 (executable)
@@ -14,6 +14,7 @@ for pkg in `find $pkg_dir -name '*.ipk' | sort`; do
        name="${pkg##*/}"
        name="${name%%_*}"
        [[ "$name" = "kernel" ]] && continue
+       [[ "$name" = "libc" ]] && continue
        echo "Generating index for package $pkg" >&2
        file_size=$(ls -l $pkg | awk '{print $5}')
        md5sum=$(md5sum $pkg | awk '{print $1}')
index 803252b..b0d0698 100644 (file)
@@ -126,6 +126,7 @@ package_index: FORCE
 package_install: FORCE
        @echo
        @echo Installing packages...
+       $(OPKG) install $(PACKAGE_DIR)/libc_*.ipk
        $(OPKG) install $(PACKAGE_DIR)/kernel_*.ipk
        $(OPKG) install $(BUILD_PACKAGES)
        rm -f $(TARGET_DIR)/usr/lib/opkg/lists/*