madwifi: remove the get_arch.mk build failure when the 'detected' arch doesn't match...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 1 Aug 2009 21:29:10 +0000 (21:29 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 1 Aug 2009 21:29:10 +0000 (21:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17084 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/patches/106-get_arch.patch

index 4873271..3140f36 100644 (file)
@@ -1,6 +1,6 @@
 --- a/scripts/get_arch.mk
 +++ b/scripts/get_arch.mk
-@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
+@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
  $(Cannot determine ARCH)
  endif
  
@@ -14,3 +14,8 @@
  # Don't allow ARCH to be overridden by a different value.
  ifeq (,$(ARCH))
  ARCH = $(ARCH-y)
+-else
+-ifneq ($(ARCH),$(ARCH-y))
+-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
+-endif
+ endif