fix a small dep bug in the docs/ dir
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Jun 2008 15:38:23 +0000 (15:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Jun 2008 15:38:23 +0000 (15:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11412 3c298f89-4303-0410-b956-a3cf2f4a3e73

docs/Makefile

index cdaf09c..8bae462 100644 (file)
@@ -1,6 +1,7 @@
 ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
+PKG_NAME=docs
 
 all: compile
 
@@ -10,7 +11,7 @@ include $(INCLUDE_DIR)/prereq.mk
 MAIN = openwrt.tex
 DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-compile:
+compile: $(TMP_DIR)/.prereq-docs
        $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
        $(NO_TRACE_MAKE) openwrt.pdf openwrt.html