tools/xz: disable shared library
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Sep 2015 14:03:21 +0000 (14:03 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Sep 2015 14:03:21 +0000 (14:03 +0000)
Force a static build of the xz utilities in order to avoid the dependency on a
shared liblzma.so which might collide with the distro version.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46907 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/xz/Makefile

index e266667..d1f1008 100644 (file)
@@ -17,6 +17,10 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       --enable-static=yes \
+       --enable-shared=no \
+
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef