cobalt: do not build userland with support for mips1
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Oct 2013 22:10:57 +0000 (22:10 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Oct 2013 22:10:57 +0000 (22:10 +0000)
Without specifying -march gcc uses -march=mips1 by default, but that
causes problems when compiling openssl. Use -march=r5000 instead to
compile a userland optimized for the CPU used on this device.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38386 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/cobalt/Makefile

index 13d3fd0..527d36d 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 FEATURES:=targz pci ext4 display
 CPU_TYPE := 5k
-CPU_CFLAGS_5k := -mtune=r5000
+CPU_CFLAGS_5k := -march=r5000
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8