add iftop packages, thanks to Benjamin Binier
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Feb 2006 15:02:07 +0000 (15:02 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 9 Feb 2006 15:02:07 +0000 (15:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3206 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/iftop/Config.in [new file with mode: 0644]
package/iftop/Makefile [new file with mode: 0644]
package/iftop/ipkg/iftop.control [new file with mode: 0644]

index 016013e..b630c77 100644 (file)
@@ -72,6 +72,7 @@ source "package/howl/Config.in"
 source "package/hostap-utils/Config.in"
 source "package/hostapd/Config.in"
 source "package/htpdate/Config.in"
+source "package/iftop/Config.in"
 source "package/ipcad/Config.in"
 source "package/iproute2/Config.in"
 source "package/iperf/Config.in"
index 93f233f..ebd7e3b 100644 (file)
@@ -64,6 +64,7 @@ package-$(BR2_COMPILE_HOWL) += howl
 package-$(BR2_PACKAGE_HTPDATE) += htpdate
 package-$(BR2_PACKAGE_ICECAST) += icecast
 package-$(BR2_PACKAGE_ID3LIB) += id3lib
+package-$(BR2_PACKAGE_IFTOP) += iftop
 package-$(BR2_PACKAGE_IPCAD) += ipcad
 package-$(BR2_PACKAGE_IPERF) += iperf
 package-$(BR2_PACKAGE_IPKG) += ipkg
@@ -287,6 +288,7 @@ gnutls-compile: libgcrypt-compile opencdk-compile libtasn1-compile
 gpsd-compile: uclibc++-compile
 icecast-compile: curl-compile libvorbisidec-compile libxml2-compile libxslt-compile
 id3lib-compile: uclibc++-compile zlib-compile
+iftop-compile: libpcap-compile libpthread-compile ncurses-compile
 ipcad-compile: libpcap-compile
 irssi-compile: glib-compile ncurses-compile
 iperf-compile: uclibc++-compile
diff --git a/package/iftop/Config.in b/package/iftop/Config.in
new file mode 100644 (file)
index 0000000..f2d41d5
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_IFTOP
+       prompt "iftop............................. display bandwith usage on an interface"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBPCAP
+       select BR2_PACKAGE_LIBNCURSES
+       select BR2_PACKAGE_LIBPTHREAD
+       help
+         iftop does for network usage what top(1) does for CPU usage. It
+         listens to network traffic on a named interface and displays a
+         table of current bandwidth usage by pairs of hosts. Handy for
+         answering the question "why is our ADSL link so slow?".
+
+         http://www.ex-parrot.com/~pdw/iftop/
diff --git a/package/iftop/Makefile b/package/iftop/Makefile
new file mode 100644 (file)
index 0000000..0ef5473
--- /dev/null
@@ -0,0 +1,65 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iftop
+PKG_VERSION:=0.17pre3
+PKG_RELEASE:=1
+PKG_MD5SUM:=6d80885e0ff642222c96bb7bd3e83f96
+
+PKG_SOURCE_URL:=http://www.ex-parrot.com/~pdw/iftop/download
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,IFTOP,iftop,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --bindir=/usr/bin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_NLS) \
+                       $(DISABLE_LARGEFILE) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC=$(TARGET_CC) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       touch $@
+
+$(IPKG_IFTOP): 
+       mkdir -p $(IDIR_IFTOP)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(IDIR_IFTOP)/usr/bin/
+       $(STRIP) $(IDIR_IFTOP)/usr/bin/*
+       $(IPKG_BUILD) $(IDIR_IFTOP) $(PACKAGE_DIR)
+
+mostlyclean:
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm -f $(PKG_BUILD_DIR)/.built
diff --git a/package/iftop/ipkg/iftop.control b/package/iftop/ipkg/iftop.control
new file mode 100644 (file)
index 0000000..ce2cbad
--- /dev/null
@@ -0,0 +1,5 @@
+Package: iftop
+Priority: optional
+Section: net
+Depends: libncurses, libpcap, libpthread
+Description: display bandwith usage on an interface