busybox: procd is now the init process
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:53:30 +0000 (16:53 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Jun 2013 16:53:30 +0000 (16:53 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36997 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile
package/busybox/config/init/Config.in
package/busybox/config/sysklogd/Config.in

index ed58fab..aed6dde 100644 (file)
@@ -17,7 +17,6 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
                http://distfiles.gentoo.org/distfiles/
 PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
 
-PKG_CONFIG_DEPENDS:=CONFIG_PROCD_INIT
 PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
 PKG_BUILD_PARALLEL:=1
 
 PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
 PKG_BUILD_PARALLEL:=1
 
index 4b3c8dd..07d94a2 100644 (file)
@@ -73,7 +73,7 @@ config BUSYBOX_CONFIG_INIT
        bool "init"
        default y
        select BUSYBOX_CONFIG_FEATURE_SYSLOG
        bool "init"
        default y
        select BUSYBOX_CONFIG_FEATURE_SYSLOG
-       depends on !PROCD_INIT
+       depends on BROKEN
        help
          init is the first program run when the system boots.
 
        help
          init is the first program run when the system boots.
 
index 087a5b4..f403a68 100644 (file)
@@ -96,7 +96,7 @@ config BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG_BUFFER_SIZE
 config BUSYBOX_CONFIG_LOGREAD
        bool "logread"
        default y
 config BUSYBOX_CONFIG_LOGREAD
        bool "logread"
        default y
-       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && !PROCD_INIT
+       depends on BUSYBOX_CONFIG_FEATURE_IPC_SYSLOG && BROKEN
        help
          If you enabled Circular Buffer support, you almost
          certainly want to enable this feature as well. This
        help
          If you enabled Circular Buffer support, you almost
          certainly want to enable this feature as well. This