[tools] patch: other tools might depend on this one
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 12:49:34 +0000 (12:49 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 12:49:34 +0000 (12:49 +0000)
Signed-off-by: Markus Stenberg <markus.stenberg@iki.fi>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38236 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile

index 6b846f8..b167a60 100644 (file)
@@ -74,6 +74,10 @@ $(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache
 tools-y += ccache
 endif
 
+# in case there is no patch tool on the host we need to make patch tool a
+# dependency for tools which have patches directory
+$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))
+
 $(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
 $(curdir)/builddirs-default := $(tools-y)