iwinfo: enable nl80211 support based on cfg80211, not mac80211
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 10:25:55 +0000 (10:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Oct 2014 10:25:55 +0000 (10:25 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42758 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iwinfo/Makefile

index db46bbc..7bd8fb2 100644 (file)
@@ -15,7 +15,7 @@ PKG_CONFIG_DEPENDS := \
        CONFIG_PACKAGE_kmod-brcm-wl-mini \
        CONFIG_PACKAGE_kmod-brcm-wl-mimo \
        CONFIG_PACKAGE_kmod-madwifi \
-       CONFIG_PACKAGE_kmod-mac80211
+       CONFIG_PACKAGE_kmod-cfg80211
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,7 +24,7 @@ define Package/libiwinfo
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Generalized Wireless Information Library (iwinfo)
-  DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny
+  DEPENDS:=+PACKAGE_kmod-cfg80211:libnl-tiny
   ABI_VERSION:=$(PKG_RELEASE)
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
 endef
@@ -76,7 +76,7 @@ IWINFO_BACKENDS := \
        $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mini),wl) \
        $(if $(CONFIG_PACKAGE_kmod-brcm-wl-mimo),wl) \
        $(if $(CONFIG_PACKAGE_kmod-madwifi),madwifi) \
-       $(if $(CONFIG_PACKAGE_kmod-mac80211),nl80211)
+       $(if $(CONFIG_PACKAGE_kmod-cfg80211),nl80211)
 
 TARGET_CFLAGS += \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \