[include] add a prereq check for umask 0022, other settings will result in broken...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Oct 2010 14:25:29 +0000 (14:25 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Oct 2010 14:25:29 +0000 (14:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23442 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index 84d3f22..afb92ff 100644 (file)
@@ -18,6 +18,13 @@ $(eval $(call Require,non-root, \
        Please do not compile as root. \
 ))
 
+define Require/umask-0022
+       [ "$$(shell umask)" -eq 22 ]
+endef
+$(eval $(call Require,umask-0022, \
+       Please compile with umask 0022. \
+))
+
 # Required for the toolchain
 define Require/working-make
        $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null