[package] kernel: the camellia module name has changed in kernel 3.4
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Oct 2012 13:04:54 +0000 (13:04 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Oct 2012 13:04:54 +0000 (13:04 +0000)
With the support for architecture optimized camellia routines, the original
camellia module got renamed to camellia_generic, account for that.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33903 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/crypto.mk

index 984ccc1..43a7cc3 100644 (file)
@@ -324,6 +324,9 @@ endef
 
 $(eval $(call KernelPackage,crypto-sha1))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+camellia_mod_suffix=_generic
+endif
 
 define KernelPackage/crypto-misc
   TITLE:=Other CryptoAPI modules
@@ -347,7 +350,7 @@ define KernelPackage/crypto-misc
        CONFIG_CRYPTO_WP512
   FILES:= \
        $(LINUX_DIR)/crypto/anubis.ko \
-       $(LINUX_DIR)/crypto/camellia.ko \
+       $(LINUX_DIR)/crypto/camellia$(camellia_mod_suffix).ko \
        $(LINUX_DIR)/crypto/cast5.ko \
        $(LINUX_DIR)/crypto/cast6.ko \
        $(LINUX_DIR)/crypto/fcrypt.ko \