lantiq: ltq-vdsl-app: cleanup Makefile
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Dec 2015 17:04:12 +0000 (17:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Dec 2015 17:04:12 +0000 (17:04 +0000)
- CONFIG_IFX_CLI is unused, couldn't find any reference to this config variable
- use disable-feature instead of enable-feature=no
- reorder configure args to have depending args together
- remove configure args which set the default value
- group enable-model and configure args which enable or disable features that
  are covered by the feature set

The config.log contains the same values as before. The vdsl_cpe_control binary
has the same checksum as before.

Signed-off-by: Mathias Kresin <openwrt@kresin.me>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47888 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/config/ltq-vdsl-app/Makefile

index fffe894..bfacccd 100644 (file)
@@ -34,31 +34,25 @@ define Package/ltq-vdsl-app/description
 endef
 
 CONFIGURE_ARGS += \
-       --with-max-device="1" \
-       --with-lines-per-device="1" \
-       --with-channels-per-line="1" \
        --enable-vrx \
+       --enable-vrx-device=vr9 \
        --enable-driver-include="-I$(STAGING_DIR)/usr/include/drv_vdsl_cpe_api" \
        --enable-device-driver-include="-I$(STAGING_DIR)/usr/include/vdsl/" \
-       --enable-add-appl-cflags="-DMAX_CLI_PIPES=1"  \
        --enable-ifxos \
        --enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
        --enable-ifxos-library="-I$(STAGING_DIR)/usr/lib" \
-       --enable-dsl-ceoc=no \
-       --enable-vrx-device=vr9 \
-       --disable-dti \
+       --enable-add-appl-cflags="-DMAX_CLI_PIPES=1"  \
        --enable-debug \
-       --enable-dsl-pm-showtime
-
-ifeq ($(CONFIG_IFX_CLI),y)
-CONFIGURE_ARGS += \
-       --enable-cli-support
-endif
+       --disable-dti \
+       --with-channels-per-line="1" \
 
 #CONFIGURE_ARGS += --enable-model=full
 #CONFIGURE_ARGS += --enable-model=lite
 #CONFIGURE_ARGS += --enable-model=footprint
-CONFIGURE_ARGS += --enable-model=typical
+CONFIGURE_ARGS += \
+       --enable-model=typical \
+       --enable-dsl-pm-showtime \
+       --disable-dsl-ceoc
 #CONFIGURE_ARGS += --enable-model=debug
 
 define Package/ltq-vdsl-app/install