load of ide modules at boot (closes: #439)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 1 Apr 2006 14:51:48 +0000 (14:51 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 1 Apr 2006 14:51:48 +0000 (14:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3565 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/Config.in
target/linux/generic-2.4/modules.mk

index e81b099..7a41675 100644 (file)
@@ -287,6 +287,12 @@ config BR2_PACKAGE_KMOD_IDE
        help
          Kernel modules for IDE support
          useful for usb mass storage devices (e.g. on WL-HDD)
+         
+         Includes:
+           - ide-core
+           - ide-detect
+           - ide-disk
+           - pdc202xx_old
 
 config BR2_PACKAGE_KMOD_LOOP
        prompt "kmod-loop......................... Loop mount support"
index 705b702..f35e9ba 100644 (file)
@@ -110,7 +110,7 @@ $(eval $(call KMOD_template,IP6TABLES,ip6tables,\
 $(eval $(call KMOD_template,IDE,ide,\
        $(MODULES_DIR)/kernel/drivers/ide/*.o \
        $(MODULES_DIR)/kernel/drivers/ide/*/*.o \
-,CONFIG_IDE))
+,CONFIG_IDE,,20,pdc202xx_old ide-core ide-detect ide-disk))
 
 $(eval $(call KMOD_template,LOOP,loop,\
     $(MODULES_DIR)/kernel/drivers/block/loop.o \