Here is LVM support for OpenWRT. It introduces 3 new packages:
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2010 01:37:02 +0000 (01:37 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 12 Feb 2010 01:37:02 +0000 (01:37 +0000)
- kmod-dm for the device mapper kernel module.
- kmod-libdevmapper for the device-mapper library.
- kmod-lvm2 for the lvm tool.
Note that it currently does not create the symlinks for all the lvm
tools, so you have to use lvm pvs rather than just pvs.
Thanks Stefan Monnier

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19595 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/files/etc/hotplug2-common.rules
package/kernel/modules/block.mk

index d6dd6e8..a7aba35 100644 (file)
@@ -34,6 +34,12 @@ DEVPATH is set, SUBSYSTEM ~~ (input) {
        makedev /dev/input/%DEVICENAME% 0644
 }
 
+DEVICENAME == device-mapper {
+       nothrottle
+       makedev /dev/mapper/control 0600
+}
+
+
 DEVPATH is set {
        nothrottle
        makedev /dev/%DEVICENAME% 0644
index b180433..34c6f99 100644 (file)
@@ -360,6 +360,35 @@ endef
 $(eval $(call KernelPackage,nbd))
 
 
+define KernelPackage/dm
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Device Mapper
+  # All the "=n" are unnecessary, they're only there
+  # to stop the config from asking the question.
+  # MIRROR is M because I've needed it for pvmove.
+  KCONFIG:= \
+       CONFIG_BLK_DEV_MD=n \
+       CONFIG_DM_DEBUG=n \
+       CONFIG_DM_CRYPT=n \
+       CONFIG_DM_UEVENT=n \
+       CONFIG_DM_DELAY=n \
+       CONFIG_DM_MULTIPATH=n \
+       CONFIG_DM_ZERO=n \
+       CONFIG_DM_SNAPSHOT=n \
+       CONFIG_MD=y \
+       CONFIG_BLK_DEV_DM \
+       CONFIG_DM_MIRROR
+  FILES:=$(LINUX_DIR)/drivers/md/dm-*.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,dm-mod dm-region-hash dm-mirror dm-log)
+endef
+
+define KernelPackage/dm/description
+ Kernel module necessary for LVM2 support
+endef
+
+$(eval $(call KernelPackage,dm))
+
+
 define KernelPackage/pata-rb153-cf
 $(call KernelPackage/ata/Depends,@TARGET_adm5120_router_le)
   TITLE:=RouterBOARD 153 CF Slot support