[package]: uboot-imx23: add new package for i.MX233 boards
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Aug 2013 19:28:06 +0000 (19:28 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Aug 2013 19:28:06 +0000 (19:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37822 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/uboot-imx23/Makefile [new file with mode: 0644]

diff --git a/package/boot/uboot-imx23/Makefile b/package/boot/uboot-imx23/Makefile
new file mode 100644 (file)
index 0000000..13f1f96
--- /dev/null
@@ -0,0 +1,87 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=u-boot
+PKG_VERSION:=2013.07
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
+PKG_MD5SUM:=8445162690052e6afd4b8f87af2bb557
+
+include $(INCLUDE_DIR)/package.mk
+
+define uboot/Default
+  TITLE:=
+  CONFIG:=
+  IMAGE:=
+endef
+
+define uboot/mx23_olinuxino
+  TITLE:=U-Boot 2013.07 for the Olinuxino i.MX233
+endef
+
+UBOOTS := \
+       mx23_olinuxino
+
+define Package/uboot/template
+define Package/uboot-imx23-$(1)
+  SECTION:=boot
+  CATEGORY:=Boot Loaders
+  DEPENDS:=@TARGET_imx23
+  TITLE:=$(2)
+  URL:=http://www.denx.de/wiki/U-Boot
+  VARIANT:=$(1)
+  MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+endef
+endef
+
+define BuildUBootPackage
+       $(eval $(uboot/Default))
+       $(eval $(uboot/$(1)))
+       $(call Package/uboot/template,$(1),$(TITLE))
+endef
+
+ifdef BUILD_VARIANT
+$(eval $(call uboot/$(BUILD_VARIANT)))
+UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
+endif
+
+define Build/Configure
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(UBOOT_CONFIG)_config
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CROSS_COMPILE=$(TARGET_CROSS) u-boot.sb
+endef
+
+
+define Package/uboot/install/default
+       $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
+       dd if=$(PKG_BUILD_DIR)/u-boot.sb of=$(BIN_DIR)/uboot-$(BOARD)-$(1).sb bs=512 seek=4
+endef
+
+define Package/uboot/install/template
+define Package/uboot-imx23-$(1)/install
+       $(call Package/uboot/install/default,$(2))
+endef
+endef
+
+$(foreach u,$(UBOOTS), \
+       $(eval $(call Package/uboot/install/template,$(u),$(u))) \
+)
+
+$(foreach u,$(UBOOTS), \
+       $(eval $(call BuildUBootPackage,$(u))) \
+       $(eval $(call BuildPackage,uboot-imx23-$(u))) \
+)