add initial support for some USB-to-serial converters
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Sep 2005 21:09:40 +0000 (21:09 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Sep 2005 21:09:40 +0000 (21:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1848 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/Config.in
target/linux/control/kmod-usb-serial-belkin.control [new file with mode: 0644]
target/linux/control/kmod-usb-serial-ftdi.control [new file with mode: 0644]
target/linux/control/kmod-usb-serial-mct-u232.control [new file with mode: 0644]
target/linux/control/kmod-usb-serial-pl2303.control [new file with mode: 0644]
target/linux/control/kmod-usb-serial.control [new file with mode: 0644]
target/linux/linux-2.4/Makefile
target/linux/linux-2.4/config/brcm
target/linux/linux-2.4/config/soekris

index 3da36ee..2c0b86f 100644 (file)
@@ -191,6 +191,31 @@ config BR2_PACKAGE_KMOD_USB2
        default m
        depends BR2_PACKAGE_KMOD_USB_CONTROLLER
 
+config BR2_PACKAGE_KMOD_USB_SERIAL
+       tristate "kmod-usb-serial - Support for USB-to-serial converters"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_CONTROLLER
+
+config BR2_PACKAGE_KMOD_USB_SERIAL_BELKIN
+       tristate "kmod-usb-serial-belkin - Support for Belkin USB-to-serial converters"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
+config BR2_PACKAGE_KMOD_USB_SERIAL_FTDI
+       tristate "kmod-usb-serial-ftdi - Support for FTDI USB-to-serial converterr"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
+config BR2_PACKAGE_KMOD_USB_SERIAL_MCT_U232
+       tristate "kmod-usb-serial-mct-u232 - Support for Magic Control Technology USB-to-Serial converters"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
+config BR2_PACKAGE_KMOD_USB_SERIAL_PL2303
+       tristate "kmod-usb-serial-pl2303 - Support for Prolific PL2303 USB-to-Serial converters"
+       default m
+       depends BR2_PACKAGE_KMOD_USB_SERIAL
+
 config BR2_PACKAGE_KMOD_USB_STORAGE
        tristate "Support for USB storage devices"
        default m
diff --git a/target/linux/control/kmod-usb-serial-belkin.control b/target/linux/control/kmod-usb-serial-belkin.control
new file mode 100644 (file)
index 0000000..708cc44
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-belkin
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Belkin USB-to-Serial converters
diff --git a/target/linux/control/kmod-usb-serial-ftdi.control b/target/linux/control/kmod-usb-serial-ftdi.control
new file mode 100644 (file)
index 0000000..16bcdca
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-ftdi
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for FTDI USB-to-Serial converters
diff --git a/target/linux/control/kmod-usb-serial-mct-u232.control b/target/linux/control/kmod-usb-serial-mct-u232.control
new file mode 100644 (file)
index 0000000..00f2038
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-mct-u232
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Magic Control Technology USB-to-Serial converters
diff --git a/target/linux/control/kmod-usb-serial-pl2303.control b/target/linux/control/kmod-usb-serial-pl2303.control
new file mode 100644 (file)
index 0000000..bccbdd8
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial-pl2303
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for Prolific PL2303 USB-to-Serial converters
diff --git a/target/linux/control/kmod-usb-serial.control b/target/linux/control/kmod-usb-serial.control
new file mode 100644 (file)
index 0000000..dda5f9d
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-usb-serial
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel Support for USB-to-Serial converters
index 9f95d72..35349d2 100644 (file)
@@ -111,6 +111,23 @@ $(eval $(call KMOD_template,USB_OHCI,usb-ohci,\
 $(eval $(call KMOD_template,USB2,usb2,\
        $(MODULES_DIR)/kernel/drivers/usb/host/ehci-hcd.o \
 ,CONFIG_USB_EHCI_HCD,kmod-usb-core,60,ehci-hcd))
+
+$(eval $(call KMOD_template,USB_SERIAL,usb-serial,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/usbserial.o \
+,CONFIG_USB_SERIAL,kmod-usb-core,60,usbserial))
+$(eval $(call KMOD_template,USB_SERIAL_BELKIN,usb-serial-belkin,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/belkin_sa.o \
+,CONFIG_USB_SERIAL_BELKIN,kmod-usb-serial,61,belkin_sa))
+$(eval $(call KMOD_template,USB_SERIAL_FTDI,usb-serial-ftdi,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/ftdi_sio.o \
+,CONFIG_USB_SERIAL_IR,kmod-usb-serial,61,ftdi_usb))
+$(eval $(call KMOD_template,USB_SERIAL_MCT_U232,usb-serial-mct-u232,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/mct_u232.o \
+,CONFIG_USB_SERIAL_MCT_U232,kmod-usb-serial,61,mct_u232))
+$(eval $(call KMOD_template,USB_SERIAL_PL2303,usb-serial-pl2303,\
+       $(MODULES_DIR)/kernel/drivers/usb/serial/pl2303.o \
+,CONFIG_USB_SERIAL_PL2303,kmod-usb-serial,61,pl2303))
+
 $(eval $(call KMOD_template,USB_STORAGE,usb-storage,\
        $(MODULES_DIR)/kernel/drivers/scsi/*.o \
        $(MODULES_DIR)/kernel/drivers/usb/storage/*.o \
index d7de2ce..312a30f 100644 (file)
@@ -1256,7 +1256,28 @@ CONFIG_USB_PWC=m
 #
 # USB Serial Converter support
 #
-# CONFIG_USB_SERIAL is not set
+CONFIG_USB_SERIAL=m
+# CONFIG_USB_SERIAL_DEBUG is not set
+CONFIG_USB_SERIAL_GENERIC=y
+CONFIG_USB_SERIAL_BELKIN=m
+# CONFIG_USB_SERIAL_WHITEHEAT is not set
+# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
+# CONFIG_USB_SERIAL_EMPEG is not set
+CONFIG_USB_SERIAL_FTDI_SIO=m
+# CONFIG_USB_SERIAL_VISOR is not set
+# CONFIG_USB_SERIAL_IPAQ is not set
+# CONFIG_USB_SERIAL_IR is not set
+# CONFIG_USB_SERIAL_EDGEPORT is not set
+# CONFIG_USB_SERIAL_EDGEPORT_TI is not set
+# CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
+# CONFIG_USB_SERIAL_KEYSPAN is not set
+CONFIG_USB_SERIAL_MCT_U232=m
+# CONFIG_USB_SERIAL_KLSI is not set
+# CONFIG_USB_SERIAL_KOBIL_SCT is not set
+CONFIG_USB_SERIAL_PL2303=m
+# CONFIG_USB_SERIAL_CYBERJACK is not set
+# CONFIG_USB_SERIAL_XIRCOM is not set
+# CONFIG_USB_SERIAL_OMNINET is not set
 
 #
 # USB Miscellaneous drivers
index af5e075..ab21229 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Automatically generated by make menuconfig: don't edit
+# Automatically generated make config: don't edit
 #
 CONFIG_X86=y
 # CONFIG_SBUS is not set
@@ -101,7 +101,6 @@ CONFIG_CARDBUS=y
 # CONFIG_HOTPLUG_PCI is not set
 # CONFIG_HOTPLUG_PCI_COMPAQ is not set
 # CONFIG_HOTPLUG_PCI_COMPAQ_NVRAM is not set
-# CONFIG_HOTPLUG_PCI_IBM is not set
 # CONFIG_HOTPLUG_PCI_SHPC is not set
 # CONFIG_HOTPLUG_PCI_SHPC_POLL_EVENT_MODE is not set
 # CONFIG_HOTPLUG_PCI_SHPC_PHPRM_LEGACY is not set
@@ -134,6 +133,10 @@ CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_CONCAT is not set
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_CMDLINE_PARTS is not set
+
+#
+# User Modules And Translation Layers
+#
 CONFIG_MTD_CHAR=y
 CONFIG_MTD_BLOCK=y
 # CONFIG_FTL is not set
@@ -186,6 +189,10 @@ CONFIG_MTD_BLOCK=y
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_MTD_MTDRAM is not set
 CONFIG_MTD_BLKMTD=y
+
+#
+# Disk-On-Chip Device Drivers
+#
 # CONFIG_MTD_DOC1000 is not set
 # CONFIG_MTD_DOC2000 is not set
 # CONFIG_MTD_DOC2001 is not set
@@ -367,6 +374,10 @@ CONFIG_IP6_NF_TARGET_MARK=m
 # CONFIG_IP_SCTP is not set
 # CONFIG_ATM is not set
 CONFIG_VLAN_8021Q=y
+
+#
+#  
+#
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
 # CONFIG_DECNET is not set
@@ -431,6 +442,10 @@ CONFIG_IDE=y
 # IDE, ATA and ATAPI Block devices
 #
 CONFIG_BLK_DEV_IDE=y
+
+#
+# Please see Documentation/ide.txt for help/info on IDE drives
+#
 # CONFIG_BLK_DEV_HD_IDE is not set
 # CONFIG_BLK_DEV_HD is not set
 # CONFIG_BLK_DEV_IDE_SATA is not set
@@ -444,6 +459,10 @@ CONFIG_IDEDISK_MULTI_MODE=y
 # CONFIG_BLK_DEV_IDEFLOPPY is not set
 # CONFIG_BLK_DEV_IDESCSI is not set
 # CONFIG_IDE_TASK_IOCTL is not set
+
+#
+# IDE chipset support/bugfixes
+#
 # CONFIG_BLK_DEV_CMD640 is not set
 # CONFIG_BLK_DEV_CMD640_ENHANCED is not set
 # CONFIG_BLK_DEV_ISAPNP is not set
@@ -499,12 +518,20 @@ CONFIG_IDEDMA_IVB=y
 # SCSI support
 #
 CONFIG_SCSI=m
+
+#
+# SCSI support type (disk, tape, CD-ROM)
+#
 CONFIG_BLK_DEV_SD=m
 CONFIG_SD_EXTRA_DEVS=5
 # CONFIG_CHR_DEV_ST is not set
 # CONFIG_CHR_DEV_OSST is not set
 # CONFIG_BLK_DEV_SR is not set
 CONFIG_CHR_DEV_SG=m
+
+#
+# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
+#
 # CONFIG_SCSI_DEBUG_QUEUES is not set
 CONFIG_SCSI_MULTI_LUN=y
 # CONFIG_SCSI_CONSTANTS is not set
@@ -721,9 +748,17 @@ CONFIG_NET_RADIO=y
 # CONFIG_PLX_HERMES is not set
 # CONFIG_TMD_HERMES is not set
 # CONFIG_PCI_HERMES is not set
+
+#
+# Wireless Pcmcia cards support
+#
 # CONFIG_PCMCIA_HERMES is not set
 # CONFIG_AIRO_CS is not set
 # CONFIG_PCMCIA_ATMEL is not set
+
+#
+# Prism54 PCI/PCMCIA GT/Duette Driver - 802.11(a/b/g)
+#
 # CONFIG_PRISM54 is not set
 CONFIG_NET_WIRELESS=y
 
@@ -814,6 +849,14 @@ CONFIG_UNIX98_PTY_COUNT=128
 # Joysticks
 #
 # CONFIG_INPUT_GAMEPORT is not set
+
+#
+# Input core support is needed for gameports
+#
+
+#
+# Input core support is needed for joysticks
+#
 # CONFIG_QIC02_TAPE is not set
 # CONFIG_IPMI_HANDLER is not set
 # CONFIG_IPMI_PANIC_EVENT is not set
@@ -880,11 +923,6 @@ CONFIG_SCx200_GPIO=m
 # CONFIG_OBMOUSE is not set
 
 #
-# Multimedia devices
-#
-# CONFIG_VIDEO_DEV is not set
-
-#
 # File systems
 #
 # CONFIG_QUOTA is not set
@@ -1058,10 +1096,12 @@ CONFIG_VIDEO_DEV=m
 #
 CONFIG_VIDEO_PROC_FS=y
 # CONFIG_I2C_PARPORT is not set
+
+#
+# Video Adapters
+#
 # CONFIG_VIDEO_BT848 is not set
 # CONFIG_VIDEO_PMS is not set
-# CONFIG_VIDEO_BWQCAM is not set
-# CONFIG_VIDEO_CQCAM is not set
 # CONFIG_VIDEO_CPIA is not set
 # CONFIG_VIDEO_SAA5249 is not set
 # CONFIG_TUNER_3036 is not set
@@ -1085,6 +1125,7 @@ CONFIG_VIDEO_PROC_FS=y
 # CONFIG_RADIO_MAXIRADIO is not set
 # CONFIG_RADIO_MAESTRO is not set
 # CONFIG_RADIO_MIROPCM20 is not set
+# CONFIG_RADIO_MIROPCM20_RDS is not set
 # CONFIG_RADIO_SF16FMI is not set
 # CONFIG_RADIO_SF16FMR2 is not set
 # CONFIG_RADIO_TERRATEC is not set
@@ -1102,16 +1143,32 @@ CONFIG_VIDEO_PROC_FS=y
 #
 CONFIG_USB=m
 # CONFIG_USB_DEBUG is not set
+
+#
+# Miscellaneous USB options
+#
 CONFIG_USB_DEVICEFS=y
 # CONFIG_USB_BANDWIDTH is not set
+
+#
+# USB Host Controller Drivers
+#
 CONFIG_USB_EHCI_HCD=m
 # CONFIG_USB_UHCI is not set
 CONFIG_USB_UHCI_ALT=m
 CONFIG_USB_OHCI=m
 # CONFIG_USB_SL811HS_ALT is not set
 # CONFIG_USB_SL811HS is not set
+
+#
+# USB Device Class drivers
+#
 # CONFIG_USB_AUDIO is not set
 # CONFIG_USB_EMI26 is not set
+
+#
+#   USB Bluetooth can only be used with disabled Bluetooth subsystem
+#
 # CONFIG_USB_MIDI is not set
 CONFIG_USB_STORAGE=m
 # CONFIG_USB_STORAGE_DEBUG is not set
@@ -1125,7 +1182,15 @@ CONFIG_USB_STORAGE_SDDR55=y
 CONFIG_USB_STORAGE_JUMPSHOT=y
 CONFIG_USB_ACM=m
 CONFIG_USB_PRINTER=m
+
+#
+# USB Human Interface Devices (HID)
+#
 # CONFIG_USB_HID is not set
+
+#
+#     Input core support is needed for USB HID input layer or HIDBP support
+#
 # CONFIG_USB_HIDINPUT is not set
 # CONFIG_USB_HIDDEV is not set
 # CONFIG_USB_KBD is not set
@@ -1134,11 +1199,19 @@ CONFIG_USB_PRINTER=m
 # CONFIG_USB_WACOM is not set
 # CONFIG_USB_KBTAB is not set
 # CONFIG_USB_POWERMATE is not set
+
+#
+# USB Imaging devices
+#
 # CONFIG_USB_DC2XX is not set
 # CONFIG_USB_MDC800 is not set
 # CONFIG_USB_SCANNER is not set
 # CONFIG_USB_MICROTEK is not set
 # CONFIG_USB_HPUSBSCSI is not set
+
+#
+# USB Multimedia devices
+#
 # CONFIG_USB_IBMCAM is not set
 # CONFIG_USB_KONICAWC is not set
 # CONFIG_USB_OV511 is not set
@@ -1149,18 +1222,51 @@ CONFIG_USB_PWC=m
 # CONFIG_USB_VICAM is not set
 # CONFIG_USB_DSBR is not set
 # CONFIG_USB_DABUSB is not set
+
+#
+# USB Network adaptors
+#
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
 # CONFIG_USB_KAWETH is not set
 # CONFIG_USB_CATC is not set
 # CONFIG_USB_CDCETHER is not set
 # CONFIG_USB_USBNET is not set
+
+#
+# USB port drivers
+#
 # CONFIG_USB_USS720 is not set
 
 #
 # USB Serial Converter support
 #
-# CONFIG_USB_SERIAL is not set
+CONFIG_USB_SERIAL=m
+# CONFIG_USB_SERIAL_DEBUG is not set
+CONFIG_USB_SERIAL_GENERIC=y
+CONFIG_USB_SERIAL_BELKIN=m
+# CONFIG_USB_SERIAL_WHITEHEAT is not set
+# CONFIG_USB_SERIAL_DIGI_ACCELEPORT is not set
+# CONFIG_USB_SERIAL_EMPEG is not set
+CONFIG_USB_SERIAL_FTDI_SIO=m
+# CONFIG_USB_SERIAL_VISOR is not set
+# CONFIG_USB_SERIAL_IPAQ is not set
+# CONFIG_USB_SERIAL_IR is not set
+# CONFIG_USB_SERIAL_EDGEPORT is not set
+# CONFIG_USB_SERIAL_EDGEPORT_TI is not set
+# CONFIG_USB_SERIAL_KEYSPAN_PDA is not set
+# CONFIG_USB_SERIAL_KEYSPAN is not set
+CONFIG_USB_SERIAL_MCT_U232=m
+# CONFIG_USB_SERIAL_KLSI is not set
+# CONFIG_USB_SERIAL_KOBIL_SCT is not set
+CONFIG_USB_SERIAL_PL2303=m
+# CONFIG_USB_SERIAL_CYBERJACK is not set
+# CONFIG_USB_SERIAL_XIRCOM is not set
+# CONFIG_USB_SERIAL_OMNINET is not set
+
+#
+# USB Miscellaneous drivers
+#
 # CONFIG_USB_RIO500 is not set
 # CONFIG_USB_AUERSWALD is not set
 # CONFIG_USB_TIGL is not set