[package] kernel: add kmod-ata-sis (#8259)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Mar 2012 18:44:30 +0000 (18:44 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Mar 2012 18:44:30 +0000 (18:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30978 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/block.mk

index a3a44b2..357f5fd 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -166,6 +166,20 @@ endef
 $(eval $(call KernelPackage,ata-sil24))
 
 
+define KernelPackage/ata-sis
+  TITLE:=SIS SATA support
+  KCONFIG:=CONFIG_SATA_SIS
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_sis.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_sis,1)
+endef
+
+define KernelPackage/ata-sis/description
+ Support for SIS Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sis))
+
+
 define KernelPackage/ata-via-sata
   TITLE:=VIA SATA support
   KCONFIG:=CONFIG_SATA_VIA