continue massive kernel menuconfig reorganization
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Oct 2005 03:01:49 +0000 (03:01 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Oct 2005 03:01:49 +0000 (03:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2298 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/Config.in
target/linux/linux-2.4/Makefile

index f360a0c..5fca0f0 100644 (file)
@@ -79,128 +79,135 @@ config BR2_PACKAGE_KMOD_BRCM_ET
        help
          Proprietary driver for Broadcom Ethernet chipsets
 
-config BR2_PACKAGE_KMOD_ARPT
-       tristate "ARP firewalling support"
-       default m
-       help
-         Kernel modules for ARP firewalling
-
-config BR2_PACKAGE_KMOD_EBT
-       tristate "Ethernet Bridge firewalling support"
-       default m
-       help
-         Kernel modules for bridge firewalling
+comment "Networking modules ------------"
 
-config BR2_PACKAGE_KMOD_IPTABLES_V4
-       tristate "Basic set of kernel modules for iptables"
-       default y
+config BR2_PACKAGE_KMOD_ATM
+       tristate "kmod-atm....................... ATM support"
+       default y if BR2_LINUX_2_4_AR7
        help
-         Kernel modules for IPv4 firewalling
+         ATM support
 
-config BR2_PACKAGE_KMOD_IPTABLES_V4_EXTRA
-       tristate "Extra modules for iptables"
+config BR2_PACKAGE_KMOD_GRE
+       tristate "kmod-gre....................... GRE tunneling driver"
        default m
        help
-         Extra kernel modules for IPv4 firewalling
+         Kernel support for GRE tunnels
 
 config BR2_PACKAGE_KMOD_IPV6
-       tristate "IPv6 support"
+       tristate "kmod-ipv6...................... IPv6 support"
        default m
        help
          Kernel modules for IPv6 protocol support
          
-config BR2_PACKAGE_KMOD_IPTABLES_V6
-       tristate "Kernel modules for ip6tables"
+config BR2_PACKAGE_KMOD_PPP
+       tristate "kmod-ppp....................... PPP support"
        default m
-       depends BR2_PACKAGE_KMOD_IPV6
        help
-         IPv6 firewalling support
+         Kernel support for PPP
 
-config BR2_PACKAGE_KMOD_IDE
-       tristate "IDE support"
+config BR2_PACKAGE_KMOD_MPPE
+       tristate   "kmod-mppe.................... PPP MPPE/MPPC module"
        default m
+       depends BR2_PACKAGE_KMOD_PPP
+       select BR2_PACKAGE_KMOD_CRYPTO
        help
-         Kernel modules for IDE support
-         useful for usb mass storage devices (e.g. on WL-HDD)
+         Support for Microsoft PPP Encryption/Compression
 
-config BR2_PACKAGE_KMOD_LOOP
-       tristate "loop mount support"
+config BR2_PACKAGE_KMOD_PPPOE
+       tristate   "kmod-pppoe................... PPPoE (PPP over Ethernet) kernel support"
        default m
+       depends BR2_PACKAGE_KMOD_PPP
        help
-         Kernel module for loop mount support
+         Support for PPP over Ethernet
 
-config BR2_PACKAGE_KMOD_NBD
-       tristate "network block device"
+config BR2_PACKAGE_KMOD_PPPOATM
+       tristate   "kmod-pppoatm................. PPPoA (PPP over ATM) kernel support"
+       default y if BR2_LINUX_2_4_AR7
        default m
+       depends BR2_PACKAGE_KMOD_PPP
+       select BR2_PACKAGE_KMOD_ATM
        help
-         Kernel module for network block device
+         Support for PPP over ATM
 
-config BR2_PACKAGE_KMOD_LP
-       tristate "parallel port and lp support"
+config BR2_PACKAGE_KMOD_SCHED
+       tristate "kmod-sched..................... Traffic schedulers"
        default m
        help
-         Kernel modules for line printer and parallel port support
+         Kernel schedulers for IP traffic
 
-config BR2_PACKAGE_KMOD_CRYPTO
-       tristate "CryptoAPI modules"
+config BR2_PACKAGE_KMOD_TUN
+       tristate "kmod-tun....................... Universal TUN/TAP driver"
        default m
-       select BUSYBOX_CONFIG_FEATURE_CHECK_TAINTED_MODULE
        help
-         Kernel modules for cryptographic algorithms
+         Kernel support for the TUN/TAP tunneling device
 
-config BR2_PACKAGE_KMOD_PPP
-       tristate "PPP support"
+
+comment "Filtering/Firewalling ---------"
+
+config BR2_PACKAGE_KMOD_ARPTABLES
+       tristate "kmod-arptables................. ARP firewalling support"
        default m
        help
-         Kernel support for PPP
+         Kernel modules for ARP firewalling
 
-config BR2_PACKAGE_KMOD_MPPE
-       tristate "PPP MPPE/MPPC module"
+config BR2_PACKAGE_KMOD_EBTABLES
+       tristate "kmod-ebtables.................. Ethernet Bridge firewalling support"
        default m
-       select BR2_PACKAGE_KMOD_CRYPTO
-       depends BR2_PACKAGE_KMOD_PPP
        help
-         Support for Microsoft PPP Encryption/Compression
+         Kernel modules for bridge firewalling
 
-config BR2_PACKAGE_KMOD_PPPOE
-       tristate "PPPoE modules"
+config BR2_PACKAGE_KMOD_IPTABLES_V4
+       tristate "kmod-iptables.................. Basic set of kernel modules for iptables"
+       default y
+       help
+         Kernel modules for IPv4 firewalling
+
+config BR2_PACKAGE_KMOD_IPTABLES_V4_EXTRA
+       tristate "kmod-iptables-extra............ Extra modules for iptables"
        default m
-       depends BR2_PACKAGE_KMOD_PPP
        help
-         Support for PPP over Ethernet
+         Extra kernel modules for IPv4 firewalling
 
-config BR2_PACKAGE_KMOD_PPPOATM
-       tristate "PPP over ATM"
-       default y if BR2_LINUX_2_4_AR7
+config BR2_PACKAGE_KMOD_IPTABLES_V6
+       tristate "kmod-ip6tables................. Kernel modules for ip6tables"
        default m
-       depends BR2_PACKAGE_KMOD_PPP
-       select BR2_PACKAGE_KMOD_ATM
+       depends BR2_PACKAGE_KMOD_IPV6
        help
-         Support for PPP over ATM
+         IPv6 firewalling support
 
-config BR2_PACKAGE_KMOD_ATM
-       tristate "ATM support"
-       default y if BR2_LINUX_2_4_AR7
+comment "Block devices support ---------"
+
+config BR2_PACKAGE_KMOD_IDE
+       tristate "kmod-ide....................... IDE support"
+       default m
        help
-         ATM support
+         Kernel modules for IDE support
+         useful for usb mass storage devices (e.g. on WL-HDD)
+         
 
-config BR2_PACKAGE_KMOD_TUN
-       tristate "Universal TUN/TAP driver"
+config BR2_PACKAGE_KMOD_LOOP
+       tristate "kmod-loop...................... loop mount support"
        default m
        help
-         Kernel support for the TUN/TAP tunneling device
+         Kernel module for loop mount support
+         
 
-config BR2_PACKAGE_KMOD_GRE
-       tristate "GRE tunneling driver"
+config BR2_PACKAGE_KMOD_NBD
+       tristate "kmod-nbd....................... network block device"
        default m
        help
-         Kernel support for GRE tunnels
+         Kernel module for network block device
+         
 
-config BR2_PACKAGE_KMOD_SCHED
-       tristate "Traffic schedulers"
+comment "Cryptographic support ---------"
+
+config BR2_PACKAGE_KMOD_CRYPTO
+       tristate "kmod-crypto.................... CryptoAPI modules"
        default m
+       select BUSYBOX_CONFIG_FEATURE_CHECK_TAINTED_MODULE
        help
-         Kernel schedulers for IP traffic
+         Kernel modules for cryptographic algorithms
+         
 
 comment "Filesystems support -----------"
 
@@ -209,24 +216,28 @@ config BR2_PACKAGE_KMOD_CIFS
        default m
        help
          Kernel modules for CIFS support
+         
 
 config BR2_PACKAGE_KMOD_FS_EXT2
        tristate "kmod-fs-ext2................... EXT2 filesystem support"
        default m
        help
          Kernel modules for EXT2 filesystem support
+         
 
 config BR2_PACKAGE_KMOD_FS_EXT3
        tristate "kmod-fs-ext3................... EXT3 filesystem support"
        default m
        help
          Kernel modules for EXT3 filesystem support
+         
 
 config BR2_PACKAGE_KMOD_FS_HFSPLUS
        tristate "kmod-fs-hfsplus................ HFS+ filesystem support"
        default m
        help
          Kernel modules for HFS+ filesystem support
+         
 
 config BR2_PACKAGE_KMOD_FS_NFS
        tristate "kmod-fs-nfs.................... NFS support"
@@ -552,6 +563,13 @@ config BR2_PACKAGE_KMOD_BLUETOOTH
          Bluetooth drivers and network stack
          
 
+config BR2_PACKAGE_KMOD_LP
+       tristate "kmod-lp........................ Parallel port and lp support"
+       default m
+       help
+         Kernel modules for line printer and parallel port support
+         
+
 config BR2_PACKAGE_KMOD_WD1100
        tristate "kmod-wd1100.................... Soekris net4801 watchdog"
        default y
index 4acbce1..4fb33d6 100644 (file)
@@ -50,66 +50,96 @@ ifeq ($(BOARD),ar7)
 include ./ar7.mk
 endif
 
+
+# Networking
+
 $(eval $(call KMOD_template,ATM,atm,\
        $(MODULES_DIR)/kernel/net/atm/atm.o \
        $(MODULES_DIR)/kernel/net/atm/br2684.o \
 ,CONFIG_ATM,,50,atm))
+
+$(eval $(call KMOD_template,GRE,gre,\
+       $(MODULES_DIR)/kernel/net/ipv4/ip_gre.o \
+,CONFIG_NET_IPGRE))
+
+$(eval $(call KMOD_template,IPV6,ipv6,\
+       $(MODULES_DIR)/kernel/net/ipv6/ipv6.o \
+,CONFIG_IPV6,,20,ipv6))
+
+$(eval $(call KMOD_template,PPP,ppp,\
+       $(MODULES_DIR)/kernel/drivers/net/ppp_async.o \
+       $(MODULES_DIR)/kernel/drivers/net/ppp_generic.o \
+       $(MODULES_DIR)/kernel/drivers/net/slhc.o \
+       $(MODULES_DIR)/kernel/drivers/net/pppox.o \
+,CONFIG_PPP))
+
+$(eval $(call KMOD_template,MPPE,mppe,\
+       $(MODULES_DIR)/kernel/drivers/net/ppp_mppe_mppc.o \
+,CONFIG_PPP_MPPE_MPPC))
+
 $(eval $(call KMOD_template,PPPOATM,pppoatm,\
        $(MODULES_DIR)/kernel/net/atm/pppoatm.o \
 ,CONFIG_PPPOATM))
-$(eval $(call KMOD_template,ARPT,arptables,\
+
+$(eval $(call KMOD_template,PPPOE,pppoe,\
+       $(MODULES_DIR)/kernel/drivers/net/pppoe.o \
+,CONFIG_PPPOE))
+
+ifneq ($(wildcard $(MODULES_DIR)/kernel/net/sched/*.o),)
+CONFIG_SCHED:=m
+endif
+$(eval $(call KMOD_template,SCHED,sched,\
+       $(MODULES_DIR)/kernel/net/sched/*.o \
+,CONFIG_SCHED))
+
+$(eval $(call KMOD_template,TUN,tun,\
+       $(MODULES_DIR)/kernel/drivers/net/tun.o \
+,CONFIG_TUN,,20,tun))
+
+
+# Filtering / Firewalling
+
+$(eval $(call KMOD_template,ARPTABLES,arptables,\
        $(MODULES_DIR)/kernel/net/ipv4/netfilter/arp*.o \
 ,CONFIG_IP_NF_ARPTABLES))
-$(eval $(call KMOD_template,EBT,ebtables,\
+
+$(eval $(call KMOD_template,EBTABLES,ebtables,\
        $(MODULES_DIR)/kernel/net/bridge/netfilter/*.o \
 ,CONFIG_BRIDGE_NF_EBTABLES))
+
 $(eval $(call KMOD_template,IPTABLES_V4_EXTRA,iptables-extra,\
        $(MODULES_DIR)/kernel/net/ipv4/netfilter/ip*.o \
 ))
+
 $(eval $(call KMOD_template,IPTABLES_V6,ip6tables,\
        $(MODULES_DIR)/kernel/net/ipv6/netfilter/ip*.o \
 ,CONFIG_IP6_NF_IPTABLES,kmod-ipv6))
-$(eval $(call KMOD_template,IPV6,ipv6,\
-       $(MODULES_DIR)/kernel/net/ipv6/ipv6.o \
-,CONFIG_IPV6,,20,ipv6))
+
+
+# Block devices
+
 $(eval $(call KMOD_template,IDE,ide,\
        $(MODULES_DIR)/kernel/drivers/ide/*.o \
        $(MODULES_DIR)/kernel/drivers/ide/*/*.o \
 ,CONFIG_IDE))
+
 $(eval $(call KMOD_template,LOOP,loop,\
     $(MODULES_DIR)/kernel/drivers/block/loop.o \
 ,CONFIG_BLK_DEV_LOOP,,20,loop))
 
+$(eval $(call KMOD_template,NBD,nbd,\
+    $(MODULES_DIR)/kernel/drivers/block/nbd.o \
+,CONFIG_BLK_DEV_NBD,,20,nbd))
+
+
+# Crypto
+
 ifneq ($(wildcard $(MODULES_DIR)/kernel/crypto/*.o),)
 CONFIG_CRYPTO:=m
 endif
 $(eval $(call KMOD_template,CRYPTO,crypto,\
        $(MODULES_DIR)/kernel/crypto/*.o \
 ,CONFIG_CRYPTO))
-$(eval $(call KMOD_template,PPP,ppp,\
-       $(MODULES_DIR)/kernel/drivers/net/ppp_async.o \
-       $(MODULES_DIR)/kernel/drivers/net/ppp_generic.o \
-       $(MODULES_DIR)/kernel/drivers/net/slhc.o \
-       $(MODULES_DIR)/kernel/drivers/net/pppox.o \
-,CONFIG_PPP))
-$(eval $(call KMOD_template,MPPE,mppe,\
-       $(MODULES_DIR)/kernel/drivers/net/ppp_mppe_mppc.o \
-,CONFIG_PPP_MPPE_MPPC))
-$(eval $(call KMOD_template,PPPOE,pppoe,\
-       $(MODULES_DIR)/kernel/drivers/net/pppoe.o \
-,CONFIG_PPPOE))
-$(eval $(call KMOD_template,TUN,tun,\
-       $(MODULES_DIR)/kernel/drivers/net/tun.o \
-,CONFIG_TUN,,20,tun))
-$(eval $(call KMOD_template,GRE,gre,\
-       $(MODULES_DIR)/kernel/net/ipv4/ip_gre.o \
-,CONFIG_NET_IPGRE))
-ifneq ($(wildcard $(MODULES_DIR)/kernel/net/sched/*.o),)
-CONFIG_SCHED:=m
-endif
-$(eval $(call KMOD_template,SCHED,sched,\
-       $(MODULES_DIR)/kernel/net/sched/*.o \
-,CONFIG_SCHED))
 
 
 # Filesystems