separate stat/debug and needed tools for configuring wlan devices, saves some space...
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Jan 2006 01:15:44 +0000 (01:15 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Jan 2006 01:15:44 +0000 (01:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2857 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile
package/madwifi-tools/Config.in
package/madwifi-tools/Makefile

index 78a8e2e..324503d 100644 (file)
@@ -118,7 +118,7 @@ package-$(BR2_PACKAGE_LRZSZ) += lrzsz
 package-$(BR2_COMPILE_LUA) += lua
 package-$(BR2_PACKAGE_MACCHANGER) += macchanger
 package-$(BR2_PACKAGE_MADPLAY) += madplay
-package-$(BR2_PACKAGE_MADWIFI_TOOLS) += madwifi-tools
+package-$(BR2_COMPILE_MADWIFI_TOOLS) += madwifi-tools
 package-$(BR2_PACKAGE_MARADNS) += maradns
 package-$(BR2_COMPILE_MATRIXSSL) += matrixssl
 package-$(BR2_PACKAGE_MIAX) += miax
index 96ff5dd..ba5e465 100644 (file)
@@ -1,5 +1,22 @@
-config BR2_PACKAGE_MADWIFI_TOOLS
-       prompt "madwifi-tools..................... Utilities for configuring the Atheros Wifi driver"
+menu "madwifi.......................... Utilities for the Atheros Wifi driver"
+
+config BR2_COMPILE_MADWIFI_TOOLS
+       tristate
+       default n
+       depends BR2_PACKAGE_MADWIFI_TOOLS_BASE || BR2_PACKAGE_MADWIFI_TOOLS_STATS
+
+config BR2_PACKAGE_MADWIFI_TOOLS_BASE
+       prompt "madwifi-tools-base................ Utilities for configuring the Atheros Wifi driver"
+       tristate
+       default y if BR2_LINUX_2_6_BRCM
+       default m if CONFIG_DEVEL
+       help
+         Driver utilities for Atheros 802.11a/b/g MiniPCI cards
+         
+         http://www.madwifi.org/
+
+config BR2_PACKAGE_MADWIFI_TOOLS_STATS
+       prompt "madwifi-tools-stats............... Debug and stat tools for the Atheros Wifi driver"
        tristate
        default m if CONFIG_DEVEL
        help
@@ -7,3 +24,4 @@ config BR2_PACKAGE_MADWIFI_TOOLS
          
          http://www.madwifi.org/
 
+endmenu
index af2e822..7ce2608 100644 (file)
@@ -15,7 +15,8 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-ng-$(PKG_VERSION)
 
 include $(TOPDIR)/package/rules.mk
 
-$(eval $(call PKG_template,MADWIFI_TOOLS,madwifi-tools,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kmod-madwifi))
+$(eval $(call PKG_template,MADWIFI_TOOLS_BASE,madwifi-tools-base,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kmod-madwifi))
+$(eval $(call PKG_template,MADWIFI_TOOLS_STATS,madwifi-tools-stats,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH),kmod-madwifi))
 
 $(PKG_BUILD_DIR)/.configured:
        touch $@
@@ -27,15 +28,23 @@ $(PKG_BUILD_DIR)/.built:
                all
        touch $@
 
-$(IPKG_MADWIFI_TOOLS):
-       install -d -m0755 $(IDIR_MADWIFI_TOOLS)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/tools/athstats \
-               $(PKG_BUILD_DIR)/tools/athdebug \
-               $(PKG_BUILD_DIR)/tools/80211stats \
-               $(PKG_BUILD_DIR)/tools/80211debug \
+$(IPKG_MADWIFI_TOOLS_BASE):
+       install -d -m0755 $(IDIR_MADWIFI_TOOLS_BASE)/usr/sbin
+       install -m0755 \
                $(PKG_BUILD_DIR)/tools/athctrl \
                $(PKG_BUILD_DIR)/tools/athkey \
                $(PKG_BUILD_DIR)/tools/wlanconfig \
-               $(IDIR_MADWIFI_TOOLS)/usr/sbin
-       $(RSTRIP) $(IDIR_MADWIFI_TOOLS)
-       $(IPKG_BUILD) $(IDIR_MADWIFI_TOOLS) $(PACKAGE_DIR)
+               $(IDIR_MADWIFI_TOOLS_BASE)/usr/sbin
+       $(RSTRIP) $(IDIR_MADWIFI_TOOLS_BASE)
+       $(IPKG_BUILD) $(IDIR_MADWIFI_TOOLS_BASE) $(PACKAGE_DIR)
+
+$(IPKG_MADWIFI_TOOLS_STATS):
+       install -d -m0755 $(IDIR_MADWIFI_TOOLS_STATS)/usr/sbin
+       install -m0755 \
+               $(PKG_BUILD_DIR)/tools/athstats \
+               $(PKG_BUILD_DIR)/tools/athdebug \
+               $(PKG_BUILD_DIR)/tools/80211stats \
+               $(PKG_BUILD_DIR)/tools/80211debug \
+               $(IDIR_MADWIFI_TOOLS_STATS)/usr/sbin
+       $(RSTRIP) $(IDIR_MADWIFI_TOOLS_STATS)
+       $(IPKG_BUILD) $(IDIR_MADWIFI_TOOLS_STATS) $(PACKAGE_DIR)