[kernel] refresh 2.6.31 patches
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Nov 2009 12:45:41 +0000 (12:45 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Nov 2009 12:45:41 +0000 (12:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18334 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic-2.6/patches-2.6.31/032-mips_vmlinux_lds.patch
target/linux/generic-2.6/patches-2.6.31/082-mtd_info_move_forward_decl.patch

index cfe2a4d..2ecf89d 100644 (file)
@@ -1,6 +1,5 @@
-diff -Nru linux-2.6.31.5/arch/mips/kernel/Makefile linux-2.6.31.5.new/arch/mips/kernel/Makefile
---- linux-2.6.31.5/arch/mips/kernel/Makefile   2009-10-25 12:35:46.137368384 +0200
-+++ linux-2.6.31.5.new/arch/mips/kernel/Makefile       2009-10-25 15:24:04.713493469 +0200
+--- a/arch/mips/kernel/Makefile
++++ b/arch/mips/kernel/Makefile
 @@ -2,6 +2,8 @@
  # Makefile for the Linux/MIPS kernel.
  #
@@ -10,10 +9,9 @@ diff -Nru linux-2.6.31.5/arch/mips/kernel/Makefile linux-2.6.31.5.new/arch/mips/
  extra-y               := head.o init_task.o vmlinux.lds
  
  obj-y         += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
-diff -Nru linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S
---- linux-2.6.31.5/arch/mips/kernel/vmlinux.lds.S      2009-10-23 01:57:56.000000000 +0300
-+++ linux-2.6.31.5.new/arch/mips/kernel/vmlinux.lds.S  2009-10-25 15:26:11.631618513 +0200
-@@ -10,15 +10,15 @@
+--- a/arch/mips/kernel/vmlinux.lds.S
++++ b/arch/mips/kernel/vmlinux.lds.S
+@@ -10,15 +10,15 @@ PHDRS {
        note PT_NOTE FLAGS(4);  /* R__ */
  }
  
index fc69082..13f0a21 100644 (file)
@@ -1,5 +1,5 @@
---- a/include/linux/mtd/partitions.h   2009-10-29 11:24:29.000000000 +0100
-+++ b/include/linux/mtd/partitions.h   2009-10-29 11:26:35.000000000 +0100
+--- a/include/linux/mtd/partitions.h
++++ b/include/linux/mtd/partitions.h
 @@ -33,6 +33,7 @@
   * Note: writeable partitions require their size and offset be
   * erasesize aligned (e.g. use MTDPART_OFS_NEXTBLK).
@@ -8,7 +8,7 @@
  
  struct mtd_partition;
  struct mtd_partition {
-@@ -49,7 +50,6 @@
+@@ -49,7 +50,6 @@ struct mtd_partition {
  #define MTDPART_SIZ_FULL      (0)