kernel: load regmap modules after kmod-lib-lzo
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Mar 2013 19:45:42 +0000 (19:45 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Mar 2013 19:45:42 +0000 (19:45 +0000)
Otherwise regmap-core will not be able to lookup the lzo exported
symbols.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36069 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index 13a0ec4..f9937be 100644 (file)
@@ -542,7 +542,7 @@ define KernelPackage/regmap
        $(LINUX_DIR)/drivers/base/regmap/regmap-core.ko \
        $(LINUX_DIR)/drivers/base/regmap/regmap-i2c.ko \
        $(LINUX_DIR)/drivers/base/regmap/regmap-spi.ko
-  AUTOLOAD:=$(call AutoLoad,10,regmap-core regmap-i2c regmap-spi)
+  AUTOLOAD:=$(call AutoLoad,21,regmap-core regmap-i2c regmap-spi)
 endef
 
 define KernelPackage/regmap/description