lldpd: allow discovery protocols to be disabled from menuconfig
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Nov 2014 09:49:20 +0000 (09:49 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Nov 2014 09:49:20 +0000 (09:49 +0000)
Signed-off-by: Michel Stam <m.stam@fugro.nl>
[jow: fixed condition for CONFIG_LLDPD_WITH_JSON]
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43233 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/lldpd/Config.in [new file with mode: 0644]
package/network/services/lldpd/Makefile
package/network/services/lldpd/patches/002-no-stack-protector.patch

diff --git a/package/network/services/lldpd/Config.in b/package/network/services/lldpd/Config.in
new file mode 100644 (file)
index 0000000..c7d4795
--- /dev/null
@@ -0,0 +1,28 @@
+menu "Configuration"
+       depends on PACKAGE_lldpd
+
+config LLDPD_WITH_CDP
+       bool
+       default y
+       prompt "Enable support for the Cisco Discovery Protocol (CDP) version 1 and 2"
+
+config LLDPD_WITH_FDP
+       bool
+       default y
+       prompt "Enable support for the Foundry Discovery Protocol (FDP)"
+
+config LLDPD_WITH_EDP
+       bool
+       default y
+       prompt "Enable support for the Extreme Discovery Protocol (EDP)"
+
+config LLDPD_WITH_SONMP
+       bool
+       default y
+       prompt "Enable support for the SynOptics Network Management Protocol"
+
+config LLDPD_WITH_JSON
+       bool
+       prompt "Enable JSON output for the LLDP Command-Line Interface"
+       default n
+endmenu
index 3a2e411..cffae63 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
-PKG_VERSION:=0.7.7
+PKG_VERSION:=0.7.10
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=9031734c69940dd79a0a175123275f83
+PKG_MD5SUM:=508f2e76703abf8420d9223aae3db548
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 PKG_LICENSE:=ISC
@@ -31,8 +31,13 @@ define Package/lldpd
   SUBMENU:=Routing and Redirection
   TITLE:=Link Layer Discovery Protocol daemon
   URL:=https://github.com/vincentbernat/lldpd/wiki
-  DEPENDS:=+libevent2 +USE_EGLIBC:libbsd
+  DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
   USERID:=lldp=121:lldp=129
+  MENU:=1
+endef
+
+define Package/lldpd/config
+source "$(SOURCE)/Config.in"
 endef
 
 define Package/lldpd/description
@@ -46,12 +51,25 @@ endef
 
 define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc/lldpd.d
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{cli,ctl,d} $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
        $(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
        $(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd
+ifneq ($(CONFIG_LLDPD_WITH_CDP),y)
+       sed -i -e '/cdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_FDP),y)
+       sed -i -e '/fdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_EDP),y)
+       sed -i -e '/edp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
+ifneq ($(CONFIG_LLDPD_WITH_SONMP),y)
+       sed -i -e '/sonmp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
 endef
 
 define Package/lldpd/conffiles
@@ -62,6 +80,13 @@ CONFIGURE_ARGS += \
        --with-privsep-user=lldp \
        --with-privsep-group=lldp \
        --with-privsep-chroot=/var/run/lldp \
-       --with-readline=no
+       --with-readline=no \
+       --with-embedded-libevent=no \
+       $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
+       $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
+       $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+       $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
+       $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)
+
 
 $(eval $(call BuildPackage,lldpd))
index dc861ba..8a49d2d 100644 (file)
@@ -1,10 +1,11 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -62,7 +62,6 @@ AX_CFLAGS_GCC_OPTION([-Wformat])
+@@ -62,7 +62,5 @@ AX_CFLAGS_GCC_OPTION([-Wformat])
  AX_CFLAGS_GCC_OPTION([-Wformat-security])
  AX_CFLAGS_GCC_OPTION([-Wcast-align])
  AX_CFLAGS_GCC_OPTION([-Winline])
 -AX_CFLAGS_GCC_OPTION([-fstack-protector])
+-AX_CFLAGS_GCC_OPTION([-fstack-protector-strong])
+ AX_CFLAGS_GCC_OPTION([-fno-omit-frame-pointer])
  AX_CFLAGS_GCC_OPTION([-D_FORTIFY_SOURCE=2])
- AX_CFLAGS_GCC_OPTION([-Wdeclaration-after-statement])
  AX_CFLAGS_GCC_OPTION([-Wno-unused-parameter])