[package] firewall: move include sourcing into a subshell, this makes the firewall...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Mar 2011 19:20:29 +0000 (19:20 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Mar 2011 19:20:29 +0000 (19:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25835 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/firewall/Makefile
package/firewall/files/lib/core_init.sh

index 3d61e09..a8a62c2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=22
+PKG_RELEASE:=23
 
 include $(INCLUDE_DIR)/package.mk
 
index c7e41e7..42124b3 100644 (file)
@@ -271,8 +271,10 @@ fw_load_notrack_zone() {
 fw_load_include() {
        local name="$1"
 
-       local path; config_get path ${name} path
-       [ -e $path ] && . $path
+       local path
+       config_get path ${name} path
+
+       [ -e $path ] && ( . $path )
 }