reenable unsupported targets on DEVELOPER=1, add binutils 2.16.91.0.6 and a missing...
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Mar 2006 10:50:51 +0000 (10:50 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Mar 2006 10:50:51 +0000 (10:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3320 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/Config.in
toolchain/binutils/2.16.91.0.6/100-uclibc-conf.patch [new file with mode: 0644]
toolchain/binutils/2.16.91.0.6/300-001_ld_makefile_patch.patch [new file with mode: 0644]
toolchain/binutils/2.16.91.0.6/300-006_better_file_error.patch [new file with mode: 0644]
toolchain/binutils/2.16.91.0.6/300-012_check_ldrunpath_length.patch [new file with mode: 0644]
toolchain/binutils/2.16.91.0.6/702-binutils-skip-comments.patch [new file with mode: 0644]
toolchain/binutils/Config.in
toolchain/gcc/4.1.0/740-sh-pr24836.patch [new file with mode: 0644]

index 03eabb7..e6e272d 100644 (file)
@@ -2,6 +2,12 @@ choice
        prompt "Target System"
        default BR2_LINUX_2_4_BRCM
        
+config BR2_LINUX_2_6_ARUBA
+       bool "Aruba [2.6]"
+       select BR2_mips
+       help
+          Build firmware images for Aruba boards 
+
 config BR2_LINUX_2_4_AR531X
        bool "Atheros AR531x [2.4]"
        select BR2_mips
@@ -9,12 +15,6 @@ config BR2_LINUX_2_4_AR531X
          Build firmware images for Atheros AR531x based boards
          (e.g. Netgear WGT624, Linksys WRT55AG)
 
-config BR2_LINUX_2_6_ARUBA
-       bool "Aruba [2.6]"
-       select BR2_mips
-       help
-          Build firmware images for Aruba boards 
-
 config BR2_LINUX_2_4_BRCM
        bool "Broadcom BCM47xx/53xx [2.4]"
        select BR2_mipsel
@@ -57,6 +57,50 @@ config BR2_LINUX_2_6_X86
          Build firmware images for x86 based boards
          (e.g. Soekris net4521 and net4801, PC Engines WRAP...)
 
+if CONFIG_DEVEL
+
+config BR2_LINUX_2_6_ARM
+       bool "UNSUPPORTED little-endian arm platform"
+       select BR2_arm
+
+config BR2_LINUX_2_6_ARMEB
+       bool "UNSUPPORTED big-endian arm platform"
+       select BR2_armeb
+
+config BR2_LINUX_2_6_CRIS
+       bool "UNSUPPORTED cris platform"
+       select BR2_cris
+
+config BR2_LINUX_2_6_M68K
+       bool "UNSUPPORTED m68k platform"
+       select BR2_m68k
+
+config BR2_LINUX_2_6_PPC
+       bool "UNSUPPORTED powerpc platform"
+       select BR2_powerpc
+
+config BR2_LINUX_2_6_SH3
+       bool "UNSUPPORTED little-endian sh3 platform"
+       select BR2_sh3
+
+config BR2_LINUX_2_6_SH3EB
+       bool "UNSUPPORTED big-endian sh3 platform"
+       select BR2_sh3eb
+
+config BR2_LINUX_2_6_SH4
+       bool "UNSUPPORTED little-endian sh4 platform"
+       select BR2_sh4
+
+config BR2_LINUX_2_6_SH4EB
+       bool "UNSUPPORTED big-endian sh4 platform"
+       select BR2_sh4eb
+
+config BR2_LINUX_2_6_SPARC
+       bool "UNSUPPORTED sparc platform"
+       select BR2_sparc
+
+endif
+
 endchoice
 
 config BR2_LINUX_PCMCIA_SUPPORT
diff --git a/toolchain/binutils/2.16.91.0.6/100-uclibc-conf.patch b/toolchain/binutils/2.16.91.0.6/100-uclibc-conf.patch
new file mode 100644 (file)
index 0000000..4c72f33
--- /dev/null
@@ -0,0 +1,200 @@
+diff -Nurp binutils-2.16.91.0.2.orig/bfd/configure binutils-2.16.91.0.2/bfd/configure
+--- binutils-2.16.91.0.2.orig/bfd/configure    2005-07-20 15:27:27.000000000 -0400
++++ binutils-2.16.91.0.2/bfd/configure 2005-08-02 00:17:47.000000000 -0400
+@@ -3585,6 +3585,11 @@ linux-gnu*)
+   lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+   ;;
++linux-uclibc*)
++  lt_cv_deplibs_check_method=pass_all
++  lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
++  ;;
++
+ netbsd* | knetbsd*-gnu)
+   if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+     lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
+diff -Nurp binutils-2.16.91.0.2.orig/binutils/configure binutils-2.16.91.0.2/binutils/configure
+--- binutils-2.16.91.0.2.orig/binutils/configure       2005-07-20 15:27:27.000000000 -0400
++++ binutils-2.16.91.0.2/binutils/configure    2005-08-02 00:17:47.000000000 -0400
+@@ -3420,6 +3420,11 @@ linux-gnu*)
+   lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+   ;;
++linux-uclibc*)
++  lt_cv_deplibs_check_method=pass_all
++  lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
++  ;;
++
+ netbsd* | knetbsd*-gnu)
+   if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+     lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
+diff -Nurp binutils-2.16.91.0.2.orig/configure binutils-2.16.91.0.2/configure
+--- binutils-2.16.91.0.2.orig/configure        2005-07-20 15:27:26.000000000 -0400
++++ binutils-2.16.91.0.2/configure     2005-08-02 00:17:47.000000000 -0400
+@@ -1130,7 +1130,7 @@ no)
+     ;;
+ "")
+     case "${target}" in
+-    *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
++    *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu | *-*-linux-uclibc*)
+         # Enable libmudflap by default in GNU and friends.
+       ;;
+     *-*-freebsd*)
+@@ -1235,7 +1235,7 @@ case "${target}" in
+   am33_2.0-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;
+-  sh-*-linux*)
++  sh*-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;    
+   sh*-*-pe|mips*-*-pe|*arm-wince-pe)
+@@ -1530,7 +1530,7 @@ case "${target}" in
+   romp-*-*)
+     noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
+     ;;
+-  sh-*-* | sh64-*-*)
++  sh*-*-* | sh64-*-*)
+     case "${host}" in
+       i[3456789]86-*-vsta) ;; # don't add gprof back in
+       i[3456789]86-*-go32*) ;; # don't add gprof back in
+diff -Nurp binutils-2.16.91.0.2.orig/configure.in binutils-2.16.91.0.2/configure.in
+--- binutils-2.16.91.0.2.orig/configure.in     2005-07-20 15:27:26.000000000 -0400
++++ binutils-2.16.91.0.2/configure.in  2005-08-02 00:17:47.000000000 -0400
+@@ -341,7 +341,7 @@ no)
+     ;;
+ "")
+     case "${target}" in
+-    *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
++    *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu | *-*-linux-uclibc*)
+         # Enable libmudflap by default in GNU and friends.
+       ;;
+     *-*-freebsd*)
+@@ -446,7 +446,7 @@ case "${target}" in
+   am33_2.0-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;
+-  sh-*-linux*)
++  sh*-*-linux*)
+     noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
+     ;;    
+   sh*-*-pe|mips*-*-pe|*arm-wince-pe)
+@@ -741,7 +741,7 @@ case "${target}" in
+   romp-*-*)
+     noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes target-libgloss ${libgcj}"
+     ;;
+-  sh-*-* | sh64-*-*)
++  sh*-*-* | sh64-*-*)
+     case "${host}" in
+       i[[3456789]]86-*-vsta) ;; # don't add gprof back in
+       i[[3456789]]86-*-go32*) ;; # don't add gprof back in
+diff -Nurp binutils-2.16.91.0.2.orig/gas/configure binutils-2.16.91.0.2/gas/configure
+--- binutils-2.16.91.0.2.orig/gas/configure    2005-07-20 15:27:27.000000000 -0400
++++ binutils-2.16.91.0.2/gas/configure 2005-08-02 00:17:47.000000000 -0400
+@@ -3421,6 +3421,11 @@ linux-gnu*)
+   lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+   ;;
++linux-uclibc*)
++  lt_cv_deplibs_check_method=pass_all
++  lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
++  ;;
++
+ netbsd* | knetbsd*-gnu)
+   if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+     lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
+diff -Nurp binutils-2.16.91.0.2.orig/gprof/configure binutils-2.16.91.0.2/gprof/configure
+--- binutils-2.16.91.0.2.orig/gprof/configure  2005-04-29 13:50:29.000000000 -0400
++++ binutils-2.16.91.0.2/gprof/configure       2005-08-02 00:17:47.000000000 -0400
+@@ -3419,6 +3419,11 @@ linux-gnu*)
+   lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+   ;;
++linux-uclibc*)
++  lt_cv_deplibs_check_method=pass_all
++  lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
++  ;;
++
+ netbsd* | knetbsd*-gnu)
+   if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+     lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
+diff -Nurp binutils-2.16.91.0.2.orig/ld/configure binutils-2.16.91.0.2/ld/configure
+--- binutils-2.16.91.0.2.orig/ld/configure     2005-06-22 16:53:35.000000000 -0400
++++ binutils-2.16.91.0.2/ld/configure  2005-08-02 00:17:47.000000000 -0400
+@@ -3422,6 +3422,11 @@ linux-gnu*)
+   lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+   ;;
++linux-uclibc*)
++  lt_cv_deplibs_check_method=pass_all
++  lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
++  ;;
++
+ netbsd* | knetbsd*-gnu)
+   if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+     lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
+diff -Nurp binutils-2.16.91.0.2.orig/libtool.m4 binutils-2.16.91.0.2/libtool.m4
+--- binutils-2.16.91.0.2.orig/libtool.m4       2005-07-20 15:27:26.000000000 -0400
++++ binutils-2.16.91.0.2/libtool.m4    2005-08-02 00:17:47.000000000 -0400
+@@ -645,6 +645,11 @@ linux-gnu*)
+   lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+   ;;
++linux-uclibc*)
++  lt_cv_deplibs_check_method=pass_all
++  lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
++  ;;
++
+ netbsd* | knetbsd*-gnu)
+   if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+     [lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$']
+diff -Nurp binutils-2.16.91.0.2.orig/ltconfig binutils-2.16.91.0.2/ltconfig
+--- binutils-2.16.91.0.2.orig/ltconfig 2005-07-20 15:27:26.000000000 -0400
++++ binutils-2.16.91.0.2/ltconfig      2005-08-02 00:17:47.000000000 -0400
+@@ -602,6 +602,7 @@ host_os=`echo $host | sed 's/^\([^-]*\)-
+ # Transform linux* to *-*-linux-gnu*, to support old configure scripts.
+ case $host_os in
++linux-uclibc*) ;;
+ linux-gnu*) ;;
+ linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
+ esac
+@@ -1270,6 +1271,23 @@ linux-gnu*)
+   dynamic_linker='GNU/Linux ld.so'
+   ;;
++linux-uclibc*)
++  version_type=linux
++  need_lib_prefix=no
++  need_version=no
++  library_names_spec='${libname}${release}.so$versuffix ${libname}${release}.so$major $libname.so'
++  soname_spec='${libname}${release}.so$major'
++  finish_cmds='PATH="\$PATH:/sbin" ldconfig -n $libdir'
++  shlibpath_var=LD_LIBRARY_PATH
++  shlibpath_overrides_runpath=no
++  # This implies no fast_install, which is unacceptable.
++  # Some rework will be needed to allow for fast_install
++  # before this can be enabled.
++  hardcode_into_libs=yes
++  # Assume using the uClibc dynamic linker.
++  dynamic_linker="uClibc ld.so"
++  ;;
++
+ netbsd*)
+   need_lib_prefix=no
+   need_version=no
+diff -Nurp binutils-2.16.91.0.2.orig/opcodes/configure binutils-2.16.91.0.2/opcodes/configure
+--- binutils-2.16.91.0.2.orig/opcodes/configure        2005-07-20 15:27:28.000000000 -0400
++++ binutils-2.16.91.0.2/opcodes/configure     2005-08-02 00:17:47.000000000 -0400
+@@ -3588,6 +3588,11 @@ linux-gnu*)
+   lt_cv_file_magic_test_file=`echo /lib/libc.so* /lib/libc-*.so`
+   ;;
++linux-uclibc*)
++  lt_cv_deplibs_check_method=pass_all
++  lt_cv_file_magic_test_file=`echo /lib/libuClibc-*.so`
++  ;;
++
+ netbsd* | knetbsd*-gnu)
+   if echo __ELF__ | $CC -E - | grep __ELF__ > /dev/null; then
+     lt_cv_deplibs_check_method='match_pattern /lib[^/\.]+\.so\.[0-9]+\.[0-9]+$'
diff --git a/toolchain/binutils/2.16.91.0.6/300-001_ld_makefile_patch.patch b/toolchain/binutils/2.16.91.0.6/300-001_ld_makefile_patch.patch
new file mode 100644 (file)
index 0000000..04a7e61
--- /dev/null
@@ -0,0 +1,50 @@
+#!/bin/sh -e
+## 001_ld_makefile_patch.dpatch
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Description: correct where ld scripts are installed
+## DP: Author: Chris Chimelis <chris@debian.org>
+## DP: Upstream status: N/A
+## DP: Date: ??
+
+if [ $# -ne 1 ]; then
+    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+    exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
+
+case "$1" in
+       -patch) patch $patch_opts -p1 < $0;;
+       -unpatch) patch $patch_opts -p1 -R < $0;;
+        *)
+                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+                exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+--- binutils-2.16.91.0.1/ld/Makefile.am
++++ binutils-2.16.91.0.1/ld/Makefile.am
+@@ -20,7 +20,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+--- binutils-2.16.91.0.1/ld/Makefile.in
++++ binutils-2.16.91.0.1/ld/Makefile.in
+@@ -268,7 +268,7 @@
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/2.16.91.0.6/300-006_better_file_error.patch b/toolchain/binutils/2.16.91.0.6/300-006_better_file_error.patch
new file mode 100644 (file)
index 0000000..f337611
--- /dev/null
@@ -0,0 +1,43 @@
+#!/bin/sh -e
+## 006_better_file_error.dpatch by David Kimdon <dwhedon@gordian.com>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Specify which filename is causing an error if the filename is a
+## DP: directory. (#45832)
+
+if [ $# -ne 1 ]; then
+    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+    exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
+
+case "$1" in
+       -patch) patch $patch_opts -p1 < $0;;
+       -unpatch) patch $patch_opts -p1 -R < $0;;
+        *)
+                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+                exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+diff -urNad /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c binutils-2.14.90.0.6/bfd/opncls.c
+--- /home/james/debian/packages/binutils/binutils-2.14.90.0.6/bfd/opncls.c     2003-07-23 16:08:09.000000000 +0100
++++ binutils-2.14.90.0.6/bfd/opncls.c  2003-09-10 22:35:00.000000000 +0100
+@@ -150,6 +150,13 @@
+ {
+   bfd *nbfd;
+   const bfd_target *target_vec;
++  struct stat s;
++
++  if (stat (filename, &s) == 0)
++    if (S_ISDIR(s.st_mode)) {
++      bfd_set_error (bfd_error_file_not_recognized);
++      return NULL;
++    }
+   nbfd = _bfd_new_bfd ();
+   if (nbfd == NULL)
diff --git a/toolchain/binutils/2.16.91.0.6/300-012_check_ldrunpath_length.patch b/toolchain/binutils/2.16.91.0.6/300-012_check_ldrunpath_length.patch
new file mode 100644 (file)
index 0000000..498651a
--- /dev/null
@@ -0,0 +1,47 @@
+#!/bin/sh -e
+## 012_check_ldrunpath_length.dpatch by Chris Chimelis <chris@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Only generate an RPATH entry if LD_RUN_PATH is not empty, for
+## DP: cases where -rpath isn't specified. (#151024)
+
+if [ $# -ne 1 ]; then
+    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+    exit 1
+fi
+
+[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
+patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
+
+case "$1" in
+       -patch) patch $patch_opts -p1 < $0;;
+       -unpatch) patch $patch_opts -p1 -R < $0;;
+        *)
+                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+                exit 1;;
+esac
+
+exit 0
+
+@DPATCH@
+diff -urNad /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em binutils-2.15/ld/emultempl/elf32.em
+--- /home/james/debian/packages/binutils/new/binutils-2.15/ld/emultempl/elf32.em       2004-05-21 23:12:58.000000000 +0100
++++ binutils-2.15/ld/emultempl/elf32.em        2004-05-21 23:12:59.000000000 +0100
+@@ -692,6 +692,8 @@
+             && command_line.rpath == NULL)
+           {
+             lib_path = (const char *) getenv ("LD_RUN_PATH");
++            if ((lib_path) && (strlen (lib_path) == 0))
++                lib_path = NULL;
+             if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
+                                                     force))
+               break;
+@@ -871,6 +873,8 @@
+   rpath = command_line.rpath;
+   if (rpath == NULL)
+     rpath = (const char *) getenv ("LD_RUN_PATH");
++  if ((rpath) && (strlen (rpath) == 0))
++      rpath = NULL;
+   if (! (bfd_elf_size_dynamic_sections
+        (output_bfd, command_line.soname, rpath,
+         command_line.filter_shlib,
diff --git a/toolchain/binutils/2.16.91.0.6/702-binutils-skip-comments.patch b/toolchain/binutils/2.16.91.0.6/702-binutils-skip-comments.patch
new file mode 100644 (file)
index 0000000..9ef7a7c
--- /dev/null
@@ -0,0 +1,93 @@
+Retrieved from http://sources.redhat.com/ml/binutils/2004-04/msg00646.html
+Fixes
+localealias.s:544: Error: junk at end of line, first unrecognized character is `,' 
+when building glibc-2.3.2 with gcc-3.4.0 and binutils-2.15.90.0.3
+
+Paths adjusted to match crosstool's patcher.
+
+Message-Id: m3n052qw2g.fsf@whitebox.m5r.de
+From: Andreas Schwab <schwab at suse dot de>
+To: Nathan Sidwell <nathan at codesourcery dot com>
+Cc: Ian Lance Taylor <ian at wasabisystems dot com>, binutils at sources dot redhat dot com
+Date: Fri, 23 Apr 2004 22:27:19 +0200
+Subject: Re: demand_empty_rest_of_line and ignore_rest_of_line
+
+Nathan Sidwell <nathan@codesourcery.com> writes:
+
+> Index: read.c
+> ===================================================================
+> RCS file: /cvs/src/src/gas/read.c,v
+> retrieving revision 1.76
+> diff -c -3 -p -r1.76 read.c
+> *** read.c   12 Mar 2004 17:48:12 -0000      1.76
+> --- read.c   18 Mar 2004 09:56:05 -0000
+> *************** read_a_source_file (char *name)
+> *** 1053,1059 ****
+>   #endif
+>        input_line_pointer--;
+>        /* Report unknown char as ignored.  */
+> !      ignore_rest_of_line ();
+>      }
+>   
+>   #ifdef md_after_pass_hook
+> --- 1053,1059 ----
+>   #endif
+>        input_line_pointer--;
+>        /* Report unknown char as ignored.  */
+> !      demand_empty_rest_of_line ();
+>      }
+>   
+>   #ifdef md_after_pass_hook
+
+This means that the unknown character is no longer ignored, despite the
+comment.  As a side effect a line starting with a line comment character
+not followed by APP in NO_APP mode now triggers an error instead of just a
+warning, breaking builds of glibc on m68k-linux.  Earlier in
+read_a_source_file where #APP is handled there is another comment that
+claims that unknown comments are ignored, when in fact they aren't (only
+the initial line comment character is skipped).
+
+Note that the presence of #APP will mess up the line counters, but
+that appears to be difficult to fix.
+
+Andreas.
+
+2004-04-23  Andreas Schwab  <schwab@suse.de>
+
+       * read.c (read_a_source_file): Ignore unknown text after line
+       comment character.  Fix misleading comment.
+
+--- binutils/gas/read.c.~1.78.~        2004-04-23 08:58:23.000000000 +0200
++++ binutils/gas/read.c        2004-04-23 21:49:01.000000000 +0200
+@@ -950,10 +950,14 @@ read_a_source_file (char *name)
+             unsigned int new_length;
+             char *tmp_buf = 0;
+-            bump_line_counters ();
+             s = input_line_pointer;
+             if (strncmp (s, "APP\n", 4))
+-              continue;       /* We ignore it */
++              {
++                /* We ignore it */
++                ignore_rest_of_line ();
++                continue;
++              }
++            bump_line_counters ();
+             s += 4;
+             sb_new (&sbuf);
+@@ -1052,7 +1056,7 @@ read_a_source_file (char *name)
+           continue;
+ #endif
+         input_line_pointer--;
+-        /* Report unknown char as ignored.  */
++        /* Report unknown char as error.  */
+         demand_empty_rest_of_line ();
+       }
+
+-- 
+Andreas Schwab, SuSE Labs, schwab@suse.de
+SuSE Linux AG, Maxfeldstra&#xC3;e 5, 90409 N&#xC3;rnberg, Germany
+Key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276 4ED5
+"And now for something completely different."
index 762bf1d..7874638 100644 (file)
@@ -25,6 +25,8 @@ choice
        config BR2_BINUTILS_VERSION_2_16_91_0_2
                bool "binutils 2.16.91.0.2"
 
+       config BR2_BINUTILS_VERSION_2_16_91_0_6
+               bool "binutils 2.16.91.0.6"
 
 endchoice
 
@@ -35,3 +37,4 @@ config BR2_BINUTILS_VERSION
        default "2.16.90.0.3"     if BR2_BINUTILS_VERSION_2_16_90_0_3
        default "2.16.91.0.1"     if BR2_BINUTILS_VERSION_2_16_91_0_1
        default "2.16.91.0.2"     if BR2_BINUTILS_VERSION_2_16_91_0_2
+       default "2.16.91.0.6"     if BR2_BINUTILS_VERSION_2_16_91_0_6
diff --git a/toolchain/gcc/4.1.0/740-sh-pr24836.patch b/toolchain/gcc/4.1.0/740-sh-pr24836.patch
new file mode 100644 (file)
index 0000000..7992282
--- /dev/null
@@ -0,0 +1,25 @@
+http://sourceforge.net/mailarchive/forum.php?thread_id=8959304&forum_id=5348
+http://gcc.gnu.org/bugzilla/show_bug.cgi?id=24836
+
+--- gcc/gcc/configure.ac       (revision 106699)
++++ gcc/gcc/configure.ac       (working copy)
+@@ -2446,7 +2446,7 @@
+       tls_first_minor=14
+       tls_as_opt="-m64 -Aesame --fatal-warnings"
+       ;;
+-  sh-*-* | sh[34]-*-*)
++  sh-*-* | sh[34]*-*-*)
+     conftest_s='
+       .section ".tdata","awT",@progbits
+ foo:  .long   25
+--- gcc/gcc/configure
++++ gcc/gcc/configure
+@@ -14846,7 +14846,7 @@
+       tls_first_minor=14
+       tls_as_opt="-m64 -Aesame --fatal-warnings"
+       ;;
+-  sh-*-* | sh[34]-*-*)
++  sh-*-* | sh[34]*-*-*)
+     conftest_s='
+       .section ".tdata","awT",@progbits
+ foo:  .long   25