[adm8668] provide a system clock to be used by the MIPS timer
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Dec 2012 22:39:52 +0000 (22:39 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 6 Dec 2012 22:39:52 +0000 (22:39 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34550 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/adm8668/files/arch/mips/adm8668/Makefile
target/linux/adm8668/files/arch/mips/adm8668/clock.c
target/linux/adm8668/files/arch/mips/adm8668/time.c
target/linux/adm8668/files/arch/mips/include/asm/mach-adm8668/adm8668.h

index ed45666..aff789c 100644 (file)
@@ -3,5 +3,5 @@
 #
 
 obj-y          := irq.o pci.o prom.o platform.o proc.o \
-                  setup.o time.o early_printk.o clock.o \
+                  setup.o clock.o time.o early_printk.o \
                   net_core.o net_intr.o
index 96d139e..6c839a2 100644 (file)
@@ -22,12 +22,19 @@ static struct clk uart_clk = {
        .rate   = ADM8668_UARTCLK_FREQ,
 };
 
+static struct clk sys_clk;
+
 struct clk *clk_get(struct device *dev, const char *id)
 {
-       const char *name = dev_name(dev);
+       const char *lookup = id;
+
+       if (dev)
+               lookup = dev_name(dev);
 
-       if (!strcmp(name, "apb:uart0"))
+       if (!strcmp(lookup, "apb:uart0"))
                return &uart_clk;
+       if (!strcmp(lookup, "sys"))
+               return &sys_clk;
 
        return ERR_PTR(-ENOENT);
 }
@@ -54,3 +61,16 @@ void clk_put(struct clk *clk)
 {
 }
 EXPORT_SYMBOL(clk_put);
+
+void __init adm8668_init_clocks(void)
+{
+       u32 adj;
+
+       /* adjustable clock selection
+        * CR3 bit 14~11, 0000 -> 175MHz, 0001 -> 180MHz, etc...
+        */
+       adj = (ADM8668_CONFIG_REG(ADM8668_CR3) >> 11) & 0xf;
+       sys_clk.rate = SYS_CLOCK + adj * 5000000;
+
+       pr_info("ADM8668 CPU clock: %lu MHz\n", sys_clk.rate / 1000000);
+}
index 047bccd..87bdd66 100644 (file)
@@ -1,17 +1,20 @@
 #include <linux/init.h>
 #include <linux/kernel.h>
+#include <linux/clk.h>
 
 #include <asm/time.h>
 #include <adm8668.h>
 
 void __init plat_time_init(void)
 {
-       int adj = (ADM8668_CONFIG_REG(ADM8668_CR3) >> 11) & 0xf;
+       struct clk *sys_clk;
 
-       /* adjustable clock selection
-          CR3 bit 14~11, 0000 -> 175MHz, 0001 -> 180MHz, etc... */
+       adm8668_init_clocks();
 
-       mips_hpt_frequency = (SYS_CLOCK + adj * 5000000) / 2;
-       printk("ADM8668 CPU clock: %d MHz\n", 2*mips_hpt_frequency / 1000000);
+       sys_clk = clk_get(NULL, "sys");
+       if (IS_ERR(sys_clk))
+               panic("unable to get system clock\n");
+
+       mips_hpt_frequency = clk_get_rate(sys_clk) / 2;
 }
 
index 1f7ab72..bb4466c 100644 (file)
 #define CRGPIO_TOGGLE(num)     \
        ADM8668_CONFIG_REG(CRGPIO_REG) ^= (1 << (6 + num))
 
+void adm8668_init_clocks(void);
+
 #endif /* __ADM8668_H__ */