change config screen,
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Aug 2005 16:22:31 +0000 (16:22 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Aug 2005 16:22:31 +0000 (16:22 +0000)
fix build dependencies,
make -mod-xml use expat instead of builtin xml impl,
bump release number.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1666 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile
package/php4/Config.in
package/php4/Makefile
package/php4/ipkg/php4-mod-xml.control

index e855e6f..0344b79 100644 (file)
@@ -105,7 +105,7 @@ package-$(BR2_PACKAGE_OPENVPN) += openvpn
 package-$(BR2_PACKAGE_OSIRIS) += osiris
 package-$(BR2_PACKAGE_PARPROUTED) += parprouted
 package-$(BR2_PACKAGE_PCRE) += pcre
-package-$(BR2_PACKAGE_PHP4) += php4
+package-$(BR2_COMPILE_PHP4) += php4
 package-$(BR2_PACKAGE_PICOCOM) += picocom
 package-$(BR2_PACKAGE_PMACCT) += pmacct
 package-$(BR2_PACKAGE_POPT) += popt
@@ -250,6 +250,7 @@ ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
 openvpn-compile: lzo-compile
 endif
 
+php4-compile: openssl-compile zlib-compile
 ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
 php4-compile: libgd-compile libpng-compile
 endif
@@ -259,9 +260,6 @@ endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_MYSQL),)
 php4-compile: mysql-compile
 endif
-ifneq ($(BR2_PACKAGE_PHP4_MOD_OPENSSL),)
-php4-compile: openssl-compile
-endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_PCRE),)
 php4-compile: pcre-compile
 endif
@@ -271,6 +269,9 @@ endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_SQLITE),)
 php4-compile: sqlite2-compile
 endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_XML),)
+php4-compile: expat-compile
+endif
 
 pmacct-compile: libpcap-compile
 ifneq ($(BR2_PACKAGE_PMACCT_MYSQL),)
index d5e50a0..d57bd82 100644 (file)
@@ -1,45 +1,64 @@
-menu "php4 - Hypertext preprocessor"
+menu "php4 - PHP4 Hypertext preprocessor"
 
-config BR2_PACKAGE_PHP4
-       prompt "php4 - Hypertext preprocessor"
+config BR2_COMPILE_PHP4
        bool
+       default n
        depends BR2_PACKAGE_PHP4_CLI || BR2_PACKAGE_PHP4_CGI || BR2_PACKAGE_PHP4_FASTCGI
-       help
-        PHP is a widely-used general-purpose scripting language that is especially 
-        suited for Web development and can be embedded into HTML.
-        
-        http://www.php.net/
         
+comment "Server API --"
 
 config BR2_PACKAGE_PHP4_CLI
        prompt "...-cli - PHP4 CLI (Command Line Interface)"
        tristate 
 #      default m if CONFIG_DEVEL
-       select BR2_PACKAGE_PHP4
+       select BR2_COMPILE_PHP4
+       select BR2_PACKAGE_LIBOPENSSL
+       select BR2_PACKAGE_ZLIB
+       help
+        PHP is a widely-used general-purpose scripting language that is especially 
+        suited for Web development and can be embedded into HTML.
+        
+        http://www.php.net/
 
 config BR2_PACKAGE_PHP4_CGI
        prompt "...-cgi - PHP4 built for CGI"
        tristate 
 #      default m if CONFIG_DEVEL
-       select BR2_PACKAGE_PHP4
+       select BR2_COMPILE_PHP4
+       select BR2_PACKAGE_LIBOPENSSL
+       select BR2_PACKAGE_ZLIB
+       help
+        PHP is a widely-used general-purpose scripting language that is especially 
+        suited for Web development and can be embedded into HTML.
+        
+        http://www.php.net/
 
 config BR2_PACKAGE_PHP4_FASTCGI
        prompt "...-fastcgi - PHP4 built for FastCGI"
        tristate 
 #      default m if CONFIG_DEVEL
-       select BR2_PACKAGE_PHP4
+       select BR2_COMPILE_PHP4
+       select BR2_PACKAGE_LIBOPENSSL
+       select BR2_PACKAGE_ZLIB
+       help
+        PHP is a widely-used general-purpose scripting language that is especially 
+        suited for Web development and can be embedded into HTML.
+        
+        http://www.php.net/
+
+comment "Extensions --"
 
 config BR2_PACKAGE_PHP4_MOD_FTP
        prompt "...-mod-ftp - FTP module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
 
 config BR2_PACKAGE_PHP4_MOD_GD
        prompt "...-mod-gd - GD graphics library module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBGD
        select BR2_PACKAGE_LIBPNG
 
@@ -47,60 +66,61 @@ config BR2_PACKAGE_PHP4_MOD_LDAP
        prompt "...-mod-ldap - LDAP module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBOPENLDAP
 
 config BR2_PACKAGE_PHP4_MOD_MYSQL
        prompt "...-mod-mysql - MySQL module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBMYSQLCLIENT
 
 config BR2_PACKAGE_PHP4_MOD_OPENSSL
        prompt "...-mod-openssl - OpenSSL module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBOPENSSL
 
 config BR2_PACKAGE_PHP4_MOD_PCRE
        prompt "...-mod-pcre - PCRE module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBPCRE
 
 config BR2_PACKAGE_PHP4_MOD_PGSQL
        prompt "...-mod-pgsql - PostgreSQL module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBPQ
 
 config BR2_PACKAGE_PHP4_MOD_SESSION
        prompt "...-mod-session - Sessions module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
 
 config BR2_PACKAGE_PHP4_MOD_SQLITE
        prompt "...-mod-sqlite - SQLite module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
        select BR2_PACKAGE_LIBSQLITE2
 
 config BR2_PACKAGE_PHP4_MOD_SOCKETS
        prompt "...-mod-sockets - Sockets module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
 
 config BR2_PACKAGE_PHP4_MOD_XML
        prompt "...-mod-xml - XML module"
        tristate 
 #      default m if CONFIG_DEVEL
-       depends BR2_PACKAGE_PHP4
+       depends BR2_COMPILE_PHP4
+       select BR2_PACKAGE_LIBEXPAT
 
 endmenu
index 478154a..a152f73 100644 (file)
@@ -4,14 +4,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=4.3.11
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=fbc67d240812136a9842bc1f2a217b7a
+
 PKG_SOURCE_URL:=http://fr.php.net/distributions/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
 
@@ -28,33 +28,43 @@ endef
 PKG_CONFIGURE_OPTS:= \
        --enable-shared \
        --disable-static \
-       --disable-ctype \
-       --disable-dom \
+       --disable-rpath \
+       --disable-debug \
+       --without-pear \
+       \
+       --with-config-file-path=/etc \
        --disable-ipv6 \
        --enable-magic-quotes \
        --enable-memory-limit \
        --disable-overload \
        --disable-short-tags \
-       --disable-tokenizer \
+       \
+       --disable-ctype \
+       --disable-dom \
        --enable-ftp=shared \
+       --without-gettext \
+       --without-iconv \
+       --disable-mbstring \
+       --disable-mbregex \
+       --with-openssl=shared,"$(STAGING_DIR)/usr" \
+         --with-kerberos=no \
+         --with-openssl-dir="$(STAGING_DIR)/usr" \
        --enable-session=shared \
        --enable-sockets=shared \
-       --enable-xml=shared \
-       --with-config-file-path=/etc \
-       --without-gettext \
-       --without-pear \
+       --disable-tokenizer \
        --with-zlib="$(STAGING_DIR)/usr" \
+         --with-zlib-dir="$(STAGING_DIR)/usr" \
 
 ifneq ($(BR2_PACKAGE_PHP4_MOD_GD),)
 PKG_CONFIGURE_OPTS+= --with-gd=shared,"$(STAGING_DIR)/usr" \
        --enable-gd-native-ttf \
-       --with-png-dir="$(STAGING_DIR)/usr" \
-       --with-zlib-dir="$(STAGING_DIR)/usr"
+       --with-png-dir="$(STAGING_DIR)/usr"
 else
 PKG_CONFIGURE_OPTS+= --without-gd
 endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_LDAP),)
 PKG_CONFIGURE_OPTS+= --with-ldap=shared,"$(STAGING_DIR)/usr"
+       --with-ldap-sasl="$(STAGING_DIR)/usr"
 else
 PKG_CONFIGURE_OPTS+= --without-ldap
 endif
@@ -63,11 +73,6 @@ PKG_CONFIGURE_OPTS+= --with-mysql=shared,"$(STAGING_DIR)/usr"
 else
 PKG_CONFIGURE_OPTS+= --without-mysql
 endif
-ifneq ($(BR2_PACKAGE_PHP4_MOD_OPENSSL),)
-PKG_CONFIGURE_OPTS+= --with-openssl=shared,"$(STAGING_DIR)/usr"
-else
-PKG_CONFIGURE_OPTS+= --without-openssl
-endif
 ifneq ($(BR2_PACKAGE_PHP4_MOD_PCRE),)
 PKG_CONFIGURE_OPTS+= --with-pcre-regex=shared,"$(STAGING_DIR)/usr"
 else
@@ -83,6 +88,12 @@ PKG_CONFIGURE_OPTS+= --with-sqlite=shared,"$(STAGING_DIR)/usr"
 else
 PKG_CONFIGURE_OPTS+= --without-sqlite
 endif
+ifneq ($(BR2_PACKAGE_PHP4_MOD_XML),)
+PKG_CONFIGURE_OPTS+= --enable-xml=shared \
+       --with-expat-dir="$(STAGING_DIR)/usr"
+else
+PKG_CONFIGURE_OPTS+= --disable-xml
+endif
 
 $(eval $(call PKG_template,PHP4_CLI,php4-cli,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,PHP4_CGI,php4-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -122,6 +133,8 @@ $(PKG_BUILD_DIR)/.built:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               LIBS="-lcrypto -lssl" \
+               php_cv_cc_rpath="no" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
@@ -130,7 +143,7 @@ $(PKG_BUILD_DIR)/.built:
                  --program-suffix="" \
                  --prefix=/usr \
                  --exec-prefix=/usr \
-                 --bindir=/usr/sbin \
+                 --bindir=/usr/bin \
                  --datadir=/usr/share \
                  --includedir=/usr/include \
                  --infodir=/usr/share/info \
@@ -156,6 +169,8 @@ $(PKG_BUILD_DIR)/.built:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               LIBS="-lcrypto -lssl" \
+               php_cv_cc_rpath="no" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
@@ -164,7 +179,7 @@ $(PKG_BUILD_DIR)/.built:
                  --program-suffix="" \
                  --prefix=/usr \
                  --exec-prefix=/usr \
-                 --bindir=/usr/sbin \
+                 --bindir=/usr/bin \
                  --datadir=/usr/share \
                  --includedir=/usr/include \
                  --infodir=/usr/share/info \
@@ -191,6 +206,8 @@ $(PKG_BUILD_DIR)/.built:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
                LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
+               LIBS="-lcrypto -lssl" \
+               php_cv_cc_rpath="no" \
                ./configure \
                  --target=$(GNU_TARGET_NAME) \
                  --host=$(GNU_TARGET_NAME) \
@@ -225,16 +242,16 @@ $(PKG_BUILD_DIR)/.built:
 $(IPKG_PHP4_CLI):
        install -m0755 -d $(IDIR_PHP4_CLI)/etc
        install -m0644 ./files/php.ini $(IDIR_PHP4_CLI)/etc/
-       install -m0755 -d $(IDIR_PHP4_CLI)/usr/sbin
-       cp -fpR $(PKG_BUILD_DIR)/php-cli $(IDIR_PHP4_CLI)/usr/sbin/php
+       install -m0755 -d $(IDIR_PHP4_CLI)/usr/bin
+       cp -fpR $(PKG_BUILD_DIR)/php-cli $(IDIR_PHP4_CLI)/usr/bin/php
        $(RSTRIP) $(IDIR_PHP4_CLI)
        $(IPKG_BUILD) $(IDIR_PHP4_CLI) $(PACKAGE_DIR)
 
 $(IPKG_PHP4_CGI):
        install -m0755 -d $(IDIR_PHP4_CGI)/etc
        install -m0644 ./files/php.ini $(IDIR_PHP4_CGI)/etc/
-       install -m0755 -d $(IDIR_PHP4_CGI)/usr/sbin
-       cp -fpR $(PKG_BUILD_DIR)/php-cgi $(IDIR_PHP4_CGI)/usr/sbin/php
+       install -m0755 -d $(IDIR_PHP4_CGI)/usr/bin
+       cp -fpR $(PKG_BUILD_DIR)/php-cgi $(IDIR_PHP4_CGI)/usr/bin/php
        $(RSTRIP) $(IDIR_PHP4_CGI)
        $(IPKG_BUILD) $(IDIR_PHP4_CGI) $(PACKAGE_DIR)
 
index e5f1828..235dd7a 100644 (file)
@@ -6,4 +6,4 @@ Architecture: [TBDL]
 Maintainer: Anael Orlinski <anael.orlinski@gmail.com>, Nico <nthill@free.fr>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/php4/
 Description: XML module for PHP4 
-Depends: php4
+Depends: php4, libexpat