Allow rdc-2.6 to kexec
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Aug 2007 19:43:45 +0000 (19:43 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Aug 2007 19:43:45 +0000 (19:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8359 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kexec-tools/Makefile
target/linux/rdc-2.6/config/default

index cfca8b1..7289930 100644 (file)
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/kexec-tools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6_X86 +zlib
+  DEPENDS:=@LINUX_2_6_X86||@LINUX_2_6_RDC +zlib
   TITLE:=Kernel boots kernel
   DESCRIPTION:=\
        kexec is a set of systems call that allows you to load \\\
@@ -32,7 +32,7 @@ endef
 MAKE_FLAGS += \
        DESTDIR="$(PKG_INSTALL_DIR)" \
        EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
-       BUILD_CFLAGS="-O2" \
+       BUILD_CFLAGS="-Os" \
        LIBS="$(TARGET_LDFLAGS) -lz" \
        install
 
index b0990e4..ec8a6e6 100644 (file)
@@ -100,6 +100,7 @@ CONFIG_ISA_DMA_API=y
 CONFIG_JFFS2_FS_DEBUG=0
 CONFIG_JFFS2_RUBIN=y
 CONFIG_JFS_FS=m
+CONFIG_KEXEC=y
 CONFIG_KTIME_SCALAR=y
 # CONFIG_KVM is not set
 CONFIG_LBD=y