add --without-nmapfe to nmap configure and add mostlyclean target for rebuild
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jun 2005 20:16:28 +0000 (20:16 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jun 2005 20:16:28 +0000 (20:16 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1221 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/nmap/Makefile

index 6e685b4..8c01084 100644 (file)
@@ -48,6 +48,7 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_LARGEFILE) \
                  $(DISABLE_NLS) \
                  --without-openssl \
+                 --without-nmapfe \
                  --with-libpcap="$(STAGING_DIR)/usr" \
                  --with-libpcre="$(STAGING_DIR)/usr" \
        );
@@ -71,3 +72,7 @@ $(IPKG_NMAP):
        cp -fpR $(PKG_INSTALL_DIR)/usr/bin/nmap $(IDIR_NMAP)/usr/bin/
        $(RSTRIP) $(IDIR_NMAP)
        $(IPKG_BUILD) $(IDIR_NMAP) $(PACKAGE_DIR)
+
+mostlyclean:
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/.built