ar71xx: build firmware image for the TP-Link TL-WDR4310 v1.0
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Jul 2012 13:38:40 +0000 (13:38 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Jul 2012 13:38:40 +0000 (13:38 +0000)
The hardware for TP-Link TL-WDR4300 v1.1 and TL-WDR4310 v1.0 is
identical, but requires different firmware headers:

TL-WDR4300:
00000040  43 00 00 01 00 00 00 01  00 00 00 00 76 fb 83 40  |C...........v..@|

TL-WDR4310:
00000040  43 10 00 01 00 00 00 01  00 00 00 00 38 2b 50 6c  |C...........8+Pl|

[juhosg: change commit message, use a different model name]

Signed-off-by: Stefan Lippers-Hollmann <s.l-h@gmx.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32683 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index 702fa7e..8c83356 100755 (executable)
@@ -126,6 +126,9 @@ tplink_board_detect() {
        "430000"*)
                model="TP-Link TL-WDR4300"
                ;;
+       "431000"*)
+               model="TP-Link TL-WDR4310"
+               ;;
        *)
                hwver=""
                ;;
index 23e6b96..74355e8 100644 (file)
@@ -95,7 +95,7 @@ $(eval $(call Profile,TLWA901))
 
 
 define Profile/TLWDR4300
-       NAME:=TP-LINK TL-WDR4300
+       NAME:=TP-LINK TL-WDR4300/ TL-WDR4310
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
index 6e2180e..6c2581d 100644 (file)
@@ -990,6 +990,7 @@ endef
 tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
 define Image/Build/Profile/TLWDR4300
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4310-v1,$(tlwdr4300_cmdline),0x43100001,1,8Mlzma)
 endef
 
 wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200