kexec-tools: Make build of kdump optional
authorgeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Aug 2009 20:11:46 +0000 (20:11 +0000)
committergeoff <geoff@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 24 Aug 2009 20:11:46 +0000 (20:11 +0000)
Most systems won't need kdump, so make its build optional.

Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17374 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kexec-tools/Makefile
package/kexec-tools/kexec-config.in

index 4374b5b..7ee1c2c 100644 (file)
@@ -56,15 +56,21 @@ CONFIGURE_VARS += \
        BUILD_CC="$(HOSTCC)" \
        TARGET_CC="$(TARGET_CC)"
 
+kexec-extra-sbin-$(CONFIG_KEXEC_TOOLS_kdump) += kdump
+
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Package/kexec-tools/install
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(1)" \
-               install
-       rm -rf $(1)/usr/man
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
+               $(addprefix $(PKG_INSTALL_DIR)/usr/sbin/, \
+                       $(kexec-extra-sbin-y)) \
+               $(kexec-extra-bin-y) \
+               $(PKG_INSTALL_DIR)/usr/sbin/kexec \
+               $(1)/usr/sbin
+
 endef
 
 $(eval $(call BuildPackage,kexec-tools))
index 7aa3f1d..25fed1b 100644 (file)
@@ -8,3 +8,12 @@ config KEXEC_TOOLS_TARGET_NAME
          Defines the target type of the kernels that kexec deals
          with. This should be the target specification of
          the kernel you're booting.
+
+config KEXEC_TOOLS_kdump
+       bool
+       prompt "kdump support"
+       depends on PACKAGE_kexec-tools
+       default n
+       help
+         Include the kdump utility.
+