remove obsolete zd1211-driver, replaced by the in-tree module
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Oct 2007 16:59:36 +0000 (16:59 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Oct 2007 16:59:36 +0000 (16:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9372 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/zd1211-driver/Makefile [deleted file]
package/zd1211-driver/patches/100-linux_2.6.22.patch [deleted file]

diff --git a/package/zd1211-driver/Makefile b/package/zd1211-driver/Makefile
deleted file mode 100644 (file)
index 1abfc03..0000000
+++ /dev/null
@@ -1,71 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: Makefile 6582 2007-03-16 20:21:39Z nbd $
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=zd1211-driver
-PKG_VERSION:=r85
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=@openwrt/
-PKG_MD5SUM:=885cf08742c95cc416258257b5842b22
-
-include $(INCLUDE_DIR)/package.mk
-
-#FIXME: add proper dependency handling on kmod-usb-core packages
-define KernelPackage/zd1211
-  SUBMENU:=Wireless Drivers
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core
-  TITLE:=Driver for Zydas 1211 based USB devices
-  FILES:=$(PKG_BUILD_DIR)/zd1211.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,60,zd1211) 
-endef
-
-define KernelPackage/zd1211/description
- This package contains a Linux driver for the ZyDAS ZD1211 802.11b/g 
- USB-WLAN-Chip.
- Initially contributed by ZyDAS, this driver is actively maintained by the 
- open source community.
-endef
-
-define Package/zd1211-utils
-  SECTION:=utils
-  CATEGORY:=Utilities
-  TITLE:=zd1211 user-space utilities
-endef
-
-define Package/zd1211-utils/description
-  zd1211 user-space utilities : 
- - apdbg
- - zd1211-sta
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               CC="$(TARGET_CC)" \
-               CPP="$(TARGET_CC)" \
-               LD="$(TARGET_CROSS)ld" \
-               KERNELVERSION="$(KERNEL)" \
-               KERNEL_SOURCE="$(LINUX_DIR)" \
-               KDIR="$(LINUX_DIR)" \
-               all
-       $(TARGET_CC) $(PKG_BUILD_DIR)/apdbg.c -o $(PKG_BUILD_DIR)/apdbg
-endef
-
-define Package/zd1211-utils/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/apdbg $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/sta $(1)/usr/sbin/$(PKG_NAME)-sta
-endef
-
-$(eval $(call Package,zd1211-utils))
-$(eval $(call KernelPackage,zd1211))
diff --git a/package/zd1211-driver/patches/100-linux_2.6.22.patch b/package/zd1211-driver/patches/100-linux_2.6.22.patch
deleted file mode 100644 (file)
index dcab23e..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-Index: zd1211-driver-r85/src/zd1205.c
-===================================================================
---- zd1211-driver-r85.orig/src/zd1205.c        2007-06-17 04:52:12.359529080 +0200
-+++ zd1211-driver-r85/src/zd1205.c     2007-06-17 04:52:18.626576344 +0200
-@@ -238,7 +238,9 @@
- //static int zd1205wext_siwtxpow(struct net_device *dev, struct iw_request_info *info, struct iw_param *rrq, char *extra);
- static int zd1205wext_giwrange(struct net_device *dev, struct iw_request_info *info, struct iw_point *data, char *extra);
- /* ath_desc: use new get_wireless_stats in 2.6.10+ */
-+#if ((WIRELESS_EXT > 12) && (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)))
- struct iw_statistics *zd1205wext_iw_get_stats(struct net_device *dev);
-+#endif
- /* ath_desc: add iwconfig commit support */
- #if WIRELESS_EXT > 12
-@@ -435,7 +437,7 @@
- struct iw_handler_def p80211wext_handler_def =
-         {
- /* ath_desc: depend on wireless version, not kernel version */
--#if WIRELESS_EXT > 16
-+#if ((WIRELESS_EXT > 16) && (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)))
-               .get_wireless_stats = &zd1205wext_iw_get_stats,
- #endif
-         num_standard:
-@@ -4159,7 +4161,11 @@
-                         skb->tail = skb->data = pHdr;
-                         /* ath_desc: fix monitor mode frame length */
-                         skb_put(skb, data_sz - PLCP_HEADER - EXTRA_INFO_LEN - CRC32_LEN);
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22))
-                         skb->mac.raw = skb->data;
-+#else
-+                                              skb_set_mac_header(skb, 0);
-+#endif
-                         skb->pkt_type = PACKET_OTHERHOST;
-                         skb->protocol = __constant_htons(ETH_P_802_2);
-                         skb->dev = dev;
-@@ -4776,7 +4782,7 @@
-  * updated, then they might be incorrect for a short while. However,
-  * since this cannot actually cause damage, no locking is used.
-  */
--#if WIRELESS_EXT > 12
-+#if ((WIRELESS_EXT > 12) && (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,22)))
- struct iw_statistics *zd1205wext_iw_get_stats(struct net_device *dev)
- {
-       struct zd1205_private *macp = dev->priv;